Skip to main content

13. Assignment to an IA

This section preserves the RFC text for DHCPv6, including message exchanges, relay behavior, DUIDs, IA_NA, IA_TA, IA_PD, DHCP options, RKAP authentication, IANA registries, normative requirements, and appendix option-appearance matrices.

Original RFC Text​

13.  Assignment to an IA

13.1.  Selecting Addresses for Assignment to an IA_NA

   A server selects addresses to be assigned to an IA_NA according to
   the address assignment policies determined by the server
   administrator and the specific information the server determines
   about the client from some combination of the following sources:

   *  The link to which the client is attached.  The server determines
      the link as follows:

      -  If the server receives the message directly from the client and
         the source address in the IP datagram in which the message was
         received is a link-local address, then the client is on the
         same link to which the interface over which the message was
         received is attached.

      -  If the server receives the message from a forwarding relay
         agent, then the client is on the same link as the one to which
         the interface, identified by the link-address field in the
         message from the relay agent, is attached.  According to
         [RFC6221], the server MUST ignore any link-address field whose
         value is zero.  The link-address in this case may come from any
         of the Relay-forward messages encapsulated in the received
         Relay-forward, and in general the most encapsulated (closest
         Relay-forward to the client) has the most useful value.

   *  The DUID supplied by the client.

   *  Other information in options supplied by the client, e.g., IA
      Address options (see Section 21.6) that include the client's
      requests for specific addresses.

   *  Other information in options supplied by the relay agent.

   By default, DHCP server implementations SHOULD NOT generate
   predictable addresses (see Section 4.7 of [RFC7721]).  Server
   implementers are encouraged to review [RFC8981], [RFC7824],
   [RFC7707], and [RFC7943] as to possible considerations for how to
   generate addresses.

   A server MUST NOT assign an address that is otherwise reserved for
   some other purpose.  For example, a server MUST NOT assign addresses
   that use a reserved IPv6 Interface Identifier [RFC5453] [RFC7136]
   [IANA-RESERVED-IID].

   See [RFC7969] for a more detailed discussion on how servers determine
   a client's location on the network.

13.2.  Assignment of Prefixes for IA_PD

   The mechanism through which the server selects prefix(es) for
   delegation is not specified in this document.  Examples of ways in
   which the server might select prefix(es) for a client include static
   assignment based on subscription to an ISP, dynamic assignment from a
   pool of available prefixes, and selection based on an external
   authority such as a RADIUS server using the Framed-IPv6-Prefix option
   as described in [RFC3162].