Skip to main content

4. Terminology

This section preserves the RFC text for DHCPv6, including message exchanges, relay behavior, DUIDs, IA_NA, IA_TA, IA_PD, DHCP options, RKAP authentication, IANA registries, normative requirements, and appendix option-appearance matrices.

Original RFC Text​

4.  Terminology

   This section defines terminology specific to IPv6 and DHCP used in
   this document.

4.1.  IPv6 Terminology

   IPv6 terminology from [RFC8200], [RFC4291], and [RFC4862] relevant to
   this specification is included below.

   address
      An IP-layer identifier for an interface or a set of interfaces.

   GUA
      Global unicast address (see [RFC4291]).

   host
      Any node that is not a router.

   IP
      Internet Protocol Version 6 (IPv6).  The terms "IPv4" and "IPv6"
      are used only in contexts where it is necessary to avoid
      ambiguity.

   interface
      A node's attachment to a link.

   link
      A communication facility or medium over which nodes can
      communicate at the link layer, i.e., the layer immediately below
      IP.  Examples are Ethernet (simple or bridged); Point-to-Point
      Protocol (PPP) and PPP over Ethernet (PPPoE) links; and Internet-
      layer (or higher) "tunnels", such as tunnels over IPv4 or IPv6
      itself.

   link-layer identifier
      A link-layer identifier for an interface -- for example, IEEE 802
      addresses for Ethernet or Token Ring network interfaces.

   link-local address
      An IPv6 address having a link-only scope, indicated by having the
      prefix (fe80::/10), that can be used to reach neighboring nodes
      attached to the same link.  Every IPv6 interface on which DHCPv6
      can reasonably be useful has a link-local address.

   multicast address
      An identifier for a set of interfaces (typically belonging to
      different nodes).  A packet sent to a multicast address is
      delivered to all interfaces identified by that address.

   neighbor
      A node attached to the same link.

   node
      A device that implements IP.

   packet
      An IP header plus payload.

   prefix
      The initial bits of an address, or a set of IP addresses that
      share the same initial bits.

   prefix length
      The number of bits in a prefix.

   router
      A node that forwards IP packets not explicitly addressed to
      itself.

   ULA
      Unique local address (see [RFC4193]).

   unicast address
      An identifier for a single interface.  A packet sent to a unicast
      address is delivered to the interface identified by that address.

4.2.  DHCP Terminology

   Terminology specific to DHCP can be found below.

   appropriate to the link
      An address is "appropriate to the link" when the address is
      consistent with the DHCP server's knowledge of the network
      topology, prefix assignment, and address assignment policies.

   binding
      A binding (or client binding) is a group of server data records
      containing the information the server has about the addresses or
      delegated prefixes in an Identity Association (IA) or
      configuration information explicitly assigned to the client.
      Configuration information that has been returned to a client
      through a policy, such as the information returned to all clients
      on the same link, does not require a binding.  A binding
      containing information about an IA is indexed by the tuple <DUID,
      IA-type, IAID> (where IA-type is the type of lease in the IA --
      for example, address or delegated prefix).  A binding containing
      configuration information for a client is indexed by <DUID>.  See
      below for definitions of DUID, IA, and IAID.

   configuration parameter
      An element of the configuration information set on the server and
      delivered to the client using DHCP.  Such parameters may be used
      to carry information to be used by a node to configure its network
      subsystem and enable communication on a link or internetwork, for
      example.

   container option
      An option that encapsulates other options (for example, the IA_NA
      option (see Section 21.4) may contain IA Address options (see
      Section 21.6)).

   DHCP
      Dynamic Host Configuration Protocol for IPv6.  The terms "DHCPv4"
      and "DHCPv6" are used only in contexts where it is necessary to
      avoid ambiguity.

   DHCP client
      Also referred to as "client".  A node that initiates requests on a
      link to obtain configuration parameters from one or more DHCP
      servers.

   DHCP domain
      A set of links managed by DHCP and operated by a single
      administrative entity.

   DHCP relay agent
      Also referred to as "relay agent".  A node that acts as an
      intermediary to deliver DHCP messages between clients and servers.
      In certain configurations, there may be more than one relay agent
      between clients and servers, so a relay agent may send DHCP
      messages to another relay agent.

   DHCP server
      This document condenses this term to "server".  A node that
      responds to requests from clients.  It may or may not be on the
      same link as the client(s).

   DUID
      A DHCP Unique Identifier for a DHCP participant.  Each DHCP client
      and server has exactly one DUID.  See Section 11 for details of
      the ways in which a DUID may be constructed.

   encapsulated option
      A DHCP option that is usually only contained in another option.
      For example, the IA Address option is contained in IA_NA options
      (see Section 21.6 and Section 21.4, respectively).  See Section 9
      of [RFC7227] for a more complete definition.

   IA
      Identity Association: a collection of leases assigned to a client.
      Each IA has an associated IAID (see below).  A client may have
      more than one IA assigned to it -- for example, one for each of
      its interfaces.  Each IA holds one type of lease; for example, an
      identity association for non-temporary addresses (IA_NA) holds
      addresses, and an identity association for prefix delegation
      (IA_PD) holds delegated prefixes.  Throughout this document, "IA"
      is used to refer to an identity association without identifying
      the type of a lease in the IA.  This document defines three IA
      types: IA_NA, IA_TA (obsoleted), and IA_PD.  Another IA type
      (IA_LL) was defined in [RFC8947] and more may be defined.

   IA option(s)
      In this document, one or more IA_NA, IA_TA (obsoleted), and/or
      IA_PD options.  Another IA type (IA_LL) was defined in [RFC8947]
      and more may be defined.

   IAID
      Identity Association Identifier: an identifier for an IA, chosen
      by the client.  Each IA has an IAID, which is chosen to be unique
      among IAIDs for IAs of a specific type that belong to that client.

   IA_NA
      Identity Association for Non-temporary Addresses: an IA that
      carries assigned addresses.  See Section 21.4 for details on the
      IA_NA option.

   IA_PD
      Identity Association for Prefix Delegation: an IA that carries
      delegated prefixes.  See Section 21.21 for details on the IA_PD
      option.

   IA_TA
      Identity Association for Temporary Addresses: an IA that carries
      temporary addresses (see [RFC8981]).  This option is obsoleted by
      this document.  See [RFC8415] for details.

   lease
      A contract by which the server grants the use of an address or
      delegated prefix to the client for a specified period of time.

   message
      A unit of data carried as the payload of a UDP datagram, exchanged
      among DHCP servers, relay agents, and clients.

   Reconfigure key
      A key supplied to a client by a server.  Used to provide security
      for Reconfigure messages (see Section 20.4 for use cases for the
      reconfigure key).

   relaying
      A DHCP relay agent relays DHCP messages between DHCP participants.

   retransmission
      Another attempt to send the same DHCP message by a client or
      server, as a result of not receiving a valid response to the
      previously sent messages.  The retransmitted message is typically
      modified prior to sending, as required by the DHCP specifications.
      In particular, the client updates the value of the Elapsed Time
      option in the retransmitted message.

   RKAP
      The Reconfiguration Key Authentication Protocol (see
      Section 20.4).

   singleton option
      An option that is allowed to appear only once as a top-level
      option or at any encapsulation level.  Most options are
      singletons.

   T1
      The time interval after which the client is expected to contact
      the server that did the assignment to extend (renew) the lifetimes
      of the addresses assigned (via IA_NA option(s)) and/or prefixes
      delegated (via IA_PD option(s)) to the client.  T1 is expressed as
      an absolute value in messages (in seconds), is conveyed within IA
      containers (currently the IA_NA and IA_PD options), and is
      interpreted as a time interval since the message's reception.  The
      value stored in the T1 field in IA options is referred to as the
      T1 value.  The actual time when the timer expires is referred to
      as the T1 time.

   T2
      The time interval after which the client is expected to contact
      any available server to extend (rebind) the lifetimes of the
      addresses assigned (via IA_NA option(s)) and/or prefixes delegated
      (via IA_PD option(s)) to the client.  T2 is expressed as an
      absolute value in messages (in seconds), is conveyed within IA
      containers (currently the IA_NA and IA_PD options), and is
      interpreted as a time interval since the message's reception.  The
      value stored in the T2 field in IA options is referred to as the
      T2 value.  The actual time when the timer expires is referred to
      as the T2 time.

   top-level option
      An option conveyed in a DHCP message directly, i.e., not
      encapsulated in any other option, as described in Section 9 of
      [RFC7227].

   transaction ID
      An opaque value used to match responses with replies initiated by
      either a client or a server.