Aller au contenu principal

13. Attribution a une IA

Cette section conserve le texte de la RFC relatif a DHCPv6, notamment les echanges de messages, le comportement des relais, les DUID, IA_NA, IA_TA, IA_PD, les options DHCP, l'authentification RKAP, les registres IANA, les exigences normatives et les matrices d'apparition des options en annexe.

Texte original de la RFC​

13.  Attribution a une IA

13.1.  Selection des adresses a attribuer a une IA_NA

   Un serveur selectionne les adresses a attribuer a une IA_NA selon
   les politiques d'attribution d'adresses definies par l'administrateur
   du serveur et selon les informations specifiques que le serveur
   determine au sujet du client a partir d'une combinaison des sources
   suivantes:

   *  Le lien auquel le client est rattache.  Le serveur determine le
      lien comme suit:

      -  Si le serveur recoit le message directement du client et que
         l'adresse source dans le datagramme IP dans lequel le message a
         ete recu est une adresse link-local, alors le client se trouve
         sur le meme lien que celui auquel est rattachee l'interface par
         laquelle le message a ete recu.

      -  Si le serveur recoit le message d'un agent relais de
         transfert, alors le client se trouve sur le meme lien que celui
         auquel est rattachee l'interface identifiee par le champ
         link-address dans le message provenant de l'agent relais.  Selon
         [RFC6221], le serveur MUST ignorer tout champ link-address dont
         la valeur est zero.  Dans ce cas, link-address peut provenir de
         n'importe lequel des messages Relay-forward encapsules dans le
         Relay-forward recu et, en general, le message le plus encapsule
         (le Relay-forward le plus proche du client) contient la valeur
         la plus utile.

   *  Le DUID fourni par le client.

   *  D'autres informations dans les options fournies par le client, par
      exemple les options IA Address (voir Section 21.6) qui incluent les
      demandes du client pour des adresses particulieres.

   *  D'autres informations dans les options fournies par l'agent relais.

   Par defaut, les implementations de serveurs DHCP SHOULD NOT generer
   des adresses previsibles (voir Section 4.7 de [RFC7721]).  Les
   implementateurs de serveurs sont encourages a examiner [RFC8981],
   [RFC7824], [RFC7707] et [RFC7943] pour les considerations possibles
   sur la facon de generer les adresses.

   Un serveur MUST NOT attribuer une adresse qui est par ailleurs
   reservee a un autre usage.  Par exemple, un serveur MUST NOT attribuer
   des adresses qui utilisent un IPv6 Interface Identifier reserve
   [RFC5453] [RFC7136] [IANA-RESERVED-IID].

   Voir [RFC7969] pour une discussion plus detaillee sur la maniere dont
   les serveurs determinent l'emplacement d'un client sur le reseau.

13.2.  Attribution de prefixes pour IA_PD

   Le mecanisme par lequel le serveur selectionne le ou les prefixes a
   deleguer n'est pas specifie dans ce document.  Les exemples de
   methodes par lesquelles le serveur peut selectionner un ou des
   prefixes pour un client incluent l'attribution statique fondee sur un
   abonnement a un ISP, l'attribution dynamique a partir d'un pool de
   prefixes disponibles et la selection fondee sur une autorite externe
   telle qu'un serveur RADIUS utilisant l'option Framed-IPv6-Prefix comme
   decrit dans [RFC3162].