Passa al contenuto principale

13. Assegnazione a una IA

Questa sezione conserva il testo della RFC su DHCPv6, inclusi scambi di messaggi, comportamento dei relay, DUID, IA_NA, IA_TA, IA_PD, opzioni DHCP, autenticazione RKAP, registri IANA, requisiti normativi e matrici in appendice sull'apparizione delle opzioni.

Testo originale della RFC​

13.  Assegnazione a una IA

13.1.  Selezione degli indirizzi da assegnare a una IA_NA

   Un server seleziona gli indirizzi da assegnare a una IA_NA secondo le
   politiche di assegnazione degli indirizzi determinate
   dall'amministratore del server e secondo le informazioni specifiche
   che il server determina sul client da una combinazione delle fonti
   seguenti:

   *  Il link a cui il client e collegato.  Il server determina il link
      come segue:

      -  Se il server riceve il messaggio direttamente dal client e
         l'indirizzo sorgente nel datagramma IP in cui il messaggio e
         stato ricevuto e un indirizzo link-local, allora il client si
         trova sullo stesso link a cui e collegata l'interfaccia tramite
         cui il messaggio e stato ricevuto.

      -  Se il server riceve il messaggio da un relay agent che inoltra,
         allora il client si trova sullo stesso link a cui e collegata
         l'interfaccia identificata dal campo link-address nel messaggio
         proveniente dal relay agent.  Secondo [RFC6221], il server MUST
         ignorare qualsiasi campo link-address il cui valore e zero.  In
         questo caso, link-address puo provenire da uno qualsiasi dei
         messaggi Relay-forward incapsulati nel Relay-forward ricevuto e,
         in generale, quello piu incapsulato (il Relay-forward piu vicino
         al client) ha il valore piu utile.

   *  Il DUID fornito dal client.

   *  Altre informazioni nelle opzioni fornite dal client, ad esempio le
      opzioni IA Address (vedere Section 21.6) che includono le
      richieste del client per indirizzi specifici.

   *  Altre informazioni nelle opzioni fornite dal relay agent.

   Per impostazione predefinita, le implementazioni di server DHCP SHOULD
   NOT generare indirizzi prevedibili (vedere Section 4.7 di [RFC7721]).
   Gli implementatori di server sono incoraggiati a esaminare [RFC8981],
   [RFC7824], [RFC7707] e [RFC7943] per possibili considerazioni su come
   generare indirizzi.

   Un server MUST NOT assegnare un indirizzo che sia altrimenti
   riservato per qualche altro scopo.  Ad esempio, un server MUST NOT
   assegnare indirizzi che usano un IPv6 Interface Identifier riservato
   [RFC5453] [RFC7136] [IANA-RESERVED-IID].

   Vedere [RFC7969] per una discussione piu dettagliata su come i server
   determinano la posizione di un client nella rete.

13.2.  Assegnazione di prefissi per IA_PD

   Il meccanismo con cui il server seleziona il prefisso o i prefissi da
   delegare non e specificato in questo documento.  Esempi di modi in cui
   il server potrebbe selezionare prefissi per un client includono
   l'assegnazione statica basata su abbonamento a un ISP, l'assegnazione
   dinamica da un pool di prefissi disponibili e la selezione basata su
   un'autorita esterna, come un server RADIUS che usa l'opzione
   Framed-IPv6-Prefix come descritto in [RFC3162].