Zum Hauptinhalt springen

13. Zuweisung zu einer IA

Dieser Abschnitt bewahrt den RFC-Text zu DHCPv6, einschliesslich Nachrichtenaustausch, Relay-Verhalten, DUIDs, IA_NA, IA_TA, IA_PD, DHCP-Optionen, RKAP-Authentifizierung, IANA-Registern, normativen Anforderungen und der Optionsvorkommensmatrizen im Anhang.

Originaler RFC-Text​

13.  Zuweisung zu einer IA

13.1.  Auswahl von Adressen zur Zuweisung zu einer IA_NA

   Ein Server waehlt Adressen, die einer IA_NA zugewiesen werden sollen,
   gemaess den vom Serveradministrator festgelegten
   Adresszuweisungsrichtlinien und den spezifischen Informationen, die
   der Server ueber den Client aus einer Kombination der folgenden
   Quellen bestimmt:

   *  Der Link, an den der Client angeschlossen ist.  Der Server bestimmt
      den Link wie folgt:

      -  Wenn der Server die Nachricht direkt vom Client empfaengt und
         die Quelladresse im IP-Datagramm, in dem die Nachricht empfangen
         wurde, eine link-local address ist, befindet sich der Client auf
         demselben Link wie die Schnittstelle, ueber die die Nachricht
         empfangen wurde.

      -  Wenn der Server die Nachricht von einem weiterleitenden Relay
         Agent empfaengt, befindet sich der Client auf demselben Link wie
         die Schnittstelle, die durch das Feld link-address in der
         Nachricht des Relay Agent identifiziert wird.  Gemaess [RFC6221]
         MUST der Server jedes Feld link-address ignorieren, dessen Wert
         null ist.  link-address kann in diesem Fall aus jeder der
         Relay-forward-Nachrichten stammen, die im empfangenen
         Relay-forward gekapselt sind; im Allgemeinen hat die am
         staerksten gekapselte Nachricht (das dem Client naechste
         Relay-forward) den nuetzlichsten Wert.

   *  Die vom Client gelieferte DUID.

   *  Andere Informationen in vom Client gelieferten Optionen, z. B. IA
      Address options (siehe Section 21.6), die die Anforderungen des
      Clients fuer bestimmte Adressen enthalten.

   *  Andere Informationen in vom Relay Agent gelieferten Optionen.

   Standardmaessig SHOULD NOT DHCP-Server-Implementierungen vorhersagbare
   Adressen erzeugen (siehe Section 4.7 von [RFC7721]).  Server-
   Implementierer werden ermutigt, [RFC8981], [RFC7824], [RFC7707] und
   [RFC7943] im Hinblick auf moegliche Ueberlegungen zur Erzeugung von
   Adressen zu pruefen.

   Ein Server MUST NOT eine Adresse zuweisen, die anderweitig fuer einen
   anderen Zweck reserviert ist.  Beispielsweise MUST NOT ein Server
   Adressen zuweisen, die einen reservierten IPv6 Interface Identifier
   verwenden [RFC5453] [RFC7136] [IANA-RESERVED-IID].

   Siehe [RFC7969] fuer eine ausfuehrlichere Diskussion darueber, wie
   Server den Standort eines Clients im Netzwerk bestimmen.

13.2.  Zuweisung von Praefixen fuer IA_PD

   Der Mechanismus, mit dem der Server Praefixe fuer die Delegation
   auswaehlt, wird in diesem Dokument nicht spezifiziert.  Beispiele fuer
   Verfahren, mit denen der Server Praefixe fuer einen Client auswaehlen
   koennte, sind statische Zuweisung auf Grundlage eines Abonnements bei
   einem ISP, dynamische Zuweisung aus einem Pool verfuegbarer Praefixe
   und Auswahl auf Grundlage einer externen Autoritaet, etwa eines
   RADIUS-Servers mit der Option Framed-IPv6-Prefix wie in [RFC3162]
   beschrieben.