跳到主要内容

Appendix D. 与 RFC 1105 的比较

Appendix D. 与 RFC 1105 的比较 (Comparison with RFC 1105)​

包括 Appendices A, B 和 C 中列出的所有变更, 以及以下内容.

为支持 BSD 4.3 版本 (BSD Version 4.3) 提供的 TCP 用户接口 (user interface), 需要对有限状态机 [RFC1105] 做少量修改.

RFC 1105 中提出的上/下/水平 (Up/Down/Horizontal) 关系概念已从协议中移除.

相对于 RFC 1105, 消息格式的变更如下:

  1. 保持时间 (Hold Time) 字段从 BGP 报头中移除, 并添加到 OPEN 消息.

  2. 版本 (Version) 字段从 BGP 报头中移除, 并添加到 OPEN 消息.

  3. 链路类型 (Link Type) 字段从 OPEN 消息中移除.

  4. OPEN CONFIRM message 被移除, 并由 KEEPALIVE message 提供的隐式确认取代.

  5. UPDATE message 的格式发生重大变化. UPDATE message 中新增字段以支持多个 path attribute.

  6. Marker field 被扩展, 且其角色被扩展为支持 authentication.

注意, RFC 1105 中规定的 BGP 通常称为 BGP-1; [RFC1163] 中规定的 BGP 称为 BGP-2; RFC 1267 中规定的 BGP 称为 BGP-3; 本文档中规定的 BGP 称为 BGP-4.