1. 引言
1. 引言 (Introduction)
BGP 是一种自治系统间 (inter-Autonomous System) 路由协议.
BGP 系统 (BGP speaking system) 的主要功能是与其他 BGP 系统交换网络可达性信息 (network reachability information). 这些网络可达性信息包含该可达性信息所经过的自治系统 (Autonomous System, AS) 列表. 这些信息足以为该可达性构建 AS 连接图 (connectivity graph), 从中可以剪除路由环路 (routing loop), 并且可以在 AS 级别强制执行某些策略决策 (policy decision).
BGP-4 提供了一组支持无类别域间路由 (Classless Inter-Domain Routing, CIDR) [RFC1518, RFC1519] 的机制. 这些机制包括支持将一组目的地 (destination) 作为 IP 前缀 (IP prefix) 进行通告, 并在 BGP 内消除网络 "类别 (class)" 的概念. BGP-4 还引入了允许路由聚合 (route aggregation) 的机制, 包括 AS 路径聚合 (AS path aggregation).
通过 BGP 交换的路由信息 (routing information) 只支持基于目的地的转发范式 (destination-based forwarding paradigm), 该范式假定路由器 (router) 仅根据数据包 (packet) 的 IP 报头 (IP header) 中携带的目的地地址 (destination address) 转发数据包. 这反过来反映了使用 BGP 能够 (以及不能够) 强制执行的策略决策 (policy decision) 集合. BGP 只能支持符合基于目的地转发范式的策略.
1.1. 常用术语定义 (Definition of Commonly Used Terms)
本节给出在 BGP 协议中具有特定含义并在全文使用的术语定义.
Adj-RIB-In
Adj-RIBs-In 包含由对等体 (peer) 通告给本地 BGP 系统 (local BGP speaker) 的未处理路由信息 (routing information).
Adj-RIB-Out
Adj-RIBs-Out 包含本地系统通过 UPDATE 消息 (UPDATE message) 向特定对等体通告的路由 (route).
Autonomous System (AS)
自治系统 (Autonomous System, AS) 的经典定义是: 由单一技术管理机构 (technical administration) 管理的一组路由器, 使用内部网关协议 (interior gateway protocol, IGP) 和公共度量 (common metric) 来确定数据包在 AS 内如何路由, 并使用自治系统间路由协议 (inter-AS routing protocol) 来确定数据包如何路由到其他 AS. 自从这个经典定义提出以来, 单个 AS 使用多个 IGP, 有时还在 AS 内使用多组度量, 已经变得常见. 使用自治系统这一术语强调这样一个事实: 即使使用多个 IGP 和度量, 一个 AS 的管理机构对其他 AS 来说仍表现为具有单一一致的内部路由规划 (interior routing plan), 并对通过它可达的目的地呈现一致的图景.
BGP Identifier
一个 4 字节无符号整数 (4-octet unsigned integer), 指示 BGP 消息发送方的 BGP 标识符 (BGP Identifier). 给定 BGP 系统会将其 BGP 标识符的值设置为分配给该 BGP 系统的某个 IP 地址. BGP 标识符的值在启动时确定, 并且对每个本地接口 (local interface) 和每个 BGP 对等体都相同.
BGP speaker
实现 BGP 的路由器.
EBGP
外部 BGP (External BGP, EBGP) (外部对等体之间的 BGP 连接).
External peer
位于与本地系统不同自治系统中的对等体.
Feasible route
接收方 (recipient) 可使用的一条已通告路由 (advertised route).
IBGP
内部 BGP (Internal BGP, IBGP) (内部对等体之间的 BGP 连接).
Internal peer
位于与本地系统相同自治系统中的对等体.
IGP
内部网关协议 (Interior Gateway Protocol, IGP) - 用于在单个自治系统内的路由器之间交换路由信息的路由协议.
Loc-RIB
Loc-RIB 包含本地 BGP 系统的决策过程 (Decision Process) 选出的路由.
NLRI
网络层可达性信息 (Network Layer Reachability Information, NLRI).
Route
一种信息单元 (information unit), 将一组目的地与到这些目的地的路径属性 (path attribute) 配对. 目的地集合是一些系统, 其 IP 地址包含在 UPDATE 消息的网络层可达性信息 (Network Layer Reachability Information, NLRI) 字段所携带的一个 IP 地址前缀中. 路径是同一 UPDATE 消息的路径属性字段中报告的信息.
RIB
路由信息库 (Routing Information Base, RIB).
Unfeasible route
先前通告过但不再可用的可行路由 (feasible route).
1.2. 需求规范 (Specification of Requirements)
本文档中的关键词 "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" 和 "OPTIONAL" 应按 RFC 2119 [RFC2119] 中的描述解释.