RFC 4271 - Border Gateway Protocol 4 (BGP-4)
- 状态: Draft Standard
- 发布日期: January 2006
- Stream: IETF
- 废弃了: RFC1771
- 勘误: 无勘误
摘要 (Abstract)
本文档讨论边界网关协议 (Border Gateway Protocol, BGP), 它是一种自治系统间 (inter-Autonomous System) 路由协议.
BGP 系统 (BGP speaking system) 的主要功能是与其他 BGP 系统交换网络可达性信息 (network reachability information). 这些网络可达性信息包括该可达性信息所经过的自治系统 (Autonomous System, AS) 列表. 这些信息足以构建该可达性的 AS 连接图 (connectivity graph), 可从中剪除路由环路 (routing loop), 并且可以在 AS 级别强制执行某些策略决策 (policy decision).
BGP-4 提供了一组支持无类别域间路由 (Classless Inter-Domain Routing, CIDR) 的机制. 这些机制包括支持将一组目的地 (destination) 作为 IP 前缀 (prefix) 进行通告, 以及在 BGP 内消除网络 "类别 (class)" 的概念. BGP-4 还引入了允许路由聚合 (route aggregation) 的机制, 包括 AS 路径聚合 (AS path aggregation).
本文档取代 RFC 1771.
目录
- 1. 简介 (Introduction)
- 2. 致谢 (Acknowledgements)
- 3. 操作摘要 (Summary of Operation)
- 4. Message 格式 (Message Formats)
- 5. Path Attribute (Path Attributes)
- 6. BGP 错误处理 (BGP Error Handling)
- 7. BGP 版本协商 (BGP Version Negotiation)
- 8. BGP Finite State Machine (FSM)
- 9. UPDATE Message 处理
- 10. BGP Timer (BGP Timers)
附录
- Appendix A. 与 RFC 1771 的比较
- Appendix B. 与 RFC 1267 的比较
- Appendix C. 与 RFC 1163 的比较
- Appendix D. 与 RFC 1105 的比较
- Appendix E. 可与 BGP 一起使用的 TCP Option
- Appendix F. 实现建议
附加章节
- 安全考虑 (Security Considerations)
- IANA 考虑 (IANA Considerations)
- 规范性参考文献 (Normative References)
- 资料性参考文献 (Informative References)
资源
- 官方 RFC: RFC 4271
- DataTracker: RFC 4271 DataTracker
- Errata: RFC Editor Errata