跳到主要内容

Appendix A. 与 RFC 1771 的比较

Appendix A. 与 RFC 1771 的比较 (Comparison with RFC 1771)​

与 [RFC1771] 相比, 本文档有大量编辑性修改 (过多, 无法在此逐一列出).

以下列出技术性变更:

  • 修改文本以反映 TCP MD5 [RFC2385], BGP Route Reflectors [RFC2796], BGP Confederations [RFC3065] 和 BGP Route Refresh [RFC2918] 等功能的使用.

  • 澄清 AGGREGATOR 属性中 BGP 标识符的使用.

  • 给出用于限制 BGP 系统从对等体接受的前缀 (prefix) 数量上限的过程.

  • BGP 系统可以为自治系统间流量工程 (inter-AS traffic engineering) 目的, 在 AS_PATH 属性中包含多个自身 AS 的实例.

  • 澄清 NEXT_HOP 的不同类型.

  • 澄清 ATOMIC_AGGREGATE 属性的使用.

  • 澄清直接下一跳 (immediate next hop) 与 NEXT_HOP 路径属性中指定的下一跳之间的关系.

  • 澄清打破平局的过程 (tie-breaking procedure).

  • 澄清路由通告 (route advertisement) 的频率.

  • 可选参数类型 1 (Optional Parameter Type 1, Authentication Information) 已废弃.

  • UPDATE 消息错误子码 7 (UPDATE Message Error Subcode 7, AS Routing Loop) 已废弃.

  • OPEN 消息错误子码 5 (OPEN Message Error Subcode 5, Authentication Failure) 已废弃.

  • 使用 Marker 字段进行认证 (authentication) 已废弃.

  • 实现 MUST 支持将 TCP MD5 [RFC2385] 用于认证.

  • 澄清 BGP FSM.