Aller au contenu principal

Appendix D. Comparison with RFC 1105 (Annexe D. Comparaison avec RFC 1105)

Appendix D. Comparison with RFC 1105 (Annexe D. Comparaison avec RFC 1105)​

Tous les changements listés dans les Annexes A, B et C, plus ce qui suit.

Des changements mineurs à la machine à états finis [RFC1105] étaient nécessaires pour accommoder l'interface utilisateur TCP fournie par la version 4.3 de BSD.

La notion de relations Up/Down/Horizontal présentée dans RFC 1105 a été supprimée du protocole.

Les changements dans le format de message par rapport à RFC 1105 sont les suivants :

  1. Le champ Hold Time a été retiré de l'en-tête BGP et ajouté au message OPEN.

  2. Le champ version a été retiré de l'en-tête BGP et ajouté au message OPEN.

  3. Le champ Link Type a été retiré du message OPEN.

  4. Le message OPEN CONFIRM a été éliminé et remplacé par une confirmation implicite, fournie par le message KEEPALIVE.

  5. Le format du message UPDATE a été modifié de manière significative. De nouveaux champs ont été ajoutés au message UPDATE pour supporter plusieurs attributs de chemin.

  6. Le champ Marker a été élargi et son rôle étendu pour supporter l'authentification.

Notez que BGP, tel que spécifié dans RFC 1105, est souvent appelé BGP-1 ; BGP, tel que spécifié dans [RFC1163], est appelé BGP-2 ; BGP, tel que spécifié dans RFC 1267, est appelé BGP-3 ; et BGP, tel que spécifié dans ce document, est appelé BGP-4.