Aller au contenu principal

IANA Considerations (Considérations IANA)

IANA Considerations (Considérations IANA)​

Tous les messages BGP contiennent un type de message sur 8 bits, pour lequel l'IANA a créé et maintient un registre intitulé « BGP Message Types ». Ce document définit les types de messages suivants :

NomValeurDéfinition
OPEN1Voir Section 4.2
UPDATE2Voir Section 4.3
NOTIFICATION3Voir Section 4.5
KEEPALIVE4Voir Section 4.4

Les affectations futures doivent être faites en utilisant soit le processus Standards Action défini dans [RFC2434], soit le processus Early IANA Allocation défini dans [RFC4020]. Les affectations consistent en un nom et une valeur.

Les messages BGP UPDATE peuvent porter un ou plusieurs attributs de chemin, où chaque attribut contient un code de type d'attribut sur 8 bits. L'IANA maintient déjà un tel registre, intitulé « BGP Path Attributes ». Ce document définit les codes de type d'attributs de chemin suivants :

NomValeurDéfinition
ORIGIN1Voir Section 5.1.1
AS_PATH2Voir Section 5.1.2
NEXT_HOP3Voir Section 5.1.3
MULTI_EXIT_DISC4Voir Section 5.1.4
LOCAL_PREF5Voir Section 5.1.5
ATOMIC_AGGREGATE6Voir Section 5.1.6
AGGREGATOR7Voir Section 5.1.7

Les affectations futures doivent être faites en utilisant soit le processus Standards Action défini dans [RFC2434], soit le processus Early IANA Allocation défini dans [RFC4020]. Les affectations consistent en un nom et une valeur.

Le message BGP NOTIFICATION porte un code d'erreur sur 8 bits, pour lequel l'IANA a créé et maintient un registre intitulé « BGP Error Codes ». Ce document définit les codes d'erreur suivants :

NomValeurDéfinition
Message Header Error1Section 6.1
OPEN Message Error2Section 6.2
UPDATE Message Error3Section 6.3
Hold Timer Expired4Section 6.5
Finite State Machine Error5Section 6.6
Cease6Section 6.7

Les affectations futures doivent être faites en utilisant soit le processus Standards Action défini dans [RFC2434], soit le processus Early IANA Allocation défini dans [RFC4020]. Les affectations consistent en un nom et une valeur.

Le message BGP NOTIFICATION porte un sous-code d'erreur sur 8 bits, où chaque sous-code doit être défini dans le contexte d'un code d'erreur particulier, et doit donc être unique uniquement dans ce contexte.

L'IANA a créé et maintient un ensemble de registres, « Error Subcodes », avec un registre séparé pour chaque code d'erreur BGP. Les affectations futures doivent être faites en utilisant soit le processus Standards Action défini dans [RFC2434], soit le processus Early IANA Allocation défini dans [RFC4020]. Les affectations consistent en un nom et une valeur.

Ce document définit les sous-codes Message Header Error suivants :

NomValeurDéfinition
Connection Not Synchronized1Voir Section 6.1
Bad Message Length2Voir Section 6.1
Bad Message Type3Voir Section 6.1

Ce document définit les sous-codes OPEN Message Error suivants :

NomValeurDéfinition
Unsupported Version Number1Voir Section 6.2
Bad Peer AS2Voir Section 6.2
Bad BGP Identifier3Voir Section 6.2
Unsupported Optional Parameter4Voir Section 6.2
[Déprécié]5Voir Annexe A
Unacceptable Hold Time6Voir Section 6.2

Ce document définit les sous-codes UPDATE Message Error suivants :

NomValeurDéfinition
Malformed Attribute List1Voir Section 6.3
Unrecognized Well-known Attribute2Voir Section 6.3
Missing Well-known Attribute3Voir Section 6.3
Attribute Flags Error4Voir Section 6.3
Attribute Length Error5Voir Section 6.3
Invalid ORIGIN Attribute6Voir Section 6.3
[Déprécié]7Voir Annexe A
Invalid NEXT_HOP Attribute8Voir Section 6.3
Optional Attribute Error9Voir Section 6.3
Invalid Network Field10Voir Section 6.3
Malformed AS_PATH11Voir Section 6.3

[RFC791] Postel, J., "Internet Protocol", STD 5, RFC 791, September 1981.

[RFC793] Postel, J., "Transmission Control Protocol", STD 7, RFC 793, September 1981.

[RFC2119] Bradner, S., "Key words for use in RFCs to Indicate Requirement Levels", BCP 14, RFC 2119, March 1997.

[RFC2385] Heffernan, A., "Protection of BGP Sessions via the TCP MD5 Signature Option", RFC 2385, August 1998.

[RFC904] Mills, D., "Exterior Gateway Protocol formal specification", RFC 904, April 1984.

[RFC1092] Rekhter, J., "EGP and policy based routing in the new NSFNET backbone", RFC 1092, February 1989.

[RFC1093] Braun, H., "NSFNET routing architecture", RFC 1093, February 1989.

[RFC1105] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol (BGP)", RFC 1105, June 1989.

[RFC1163] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol (BGP)", RFC 1163, June 1990.

[RFC1267] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol 3 (BGP-3)", RFC 1267, October 1991.

[RFC1771] Rekhter, Y. and T. Li, "A Border Gateway Protocol 4 (BGP- 4)", RFC 1771, March 1995.

[RFC1772] Rekhter, Y. and P. Gross, "Application of the Border Gateway Protocol in the Internet", RFC 1772, March 1995.

[RFC1518] Rekhter, Y. and T. Li, "An Architecture for IP Address Allocation with CIDR", RFC 1518, September 1993.

[RFC1519] Fuller, V., Li, T., Yu, J., and K. Varadhan, "Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy", RFC 1519, September 1993.

[RFC1930] Hawkinson, J. and T. Bates, "Guidelines for creation, selection, and registration of an Autonomous System (AS)", BCP 6, RFC 1930, March 1996.

[RFC1997] Chandra, R., Traina, P., and T. Li, "BGP Communities Attribute", RFC 1997, August 1996.

[RFC2439] Villamizar, C., Chandra, R., and R. Govindan, "BGP Route Flap Damping", RFC 2439, November 1998.

[RFC2474] Nichols, K., Blake, S., Baker, F., and D. Black, "Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers", RFC 2474, December 1998.

[RFC2796] Bates, T., Chandra, R., and E. Chen, "BGP Route Reflection - An Alternative to Full Mesh IBGP", RFC 2796, April 2000.

[RFC2858] Bates, T., Rekhter, Y., Chandra, R., and D. Katz, "Multiprotocol Extensions for BGP-4", RFC 2858, June 2000.

[RFC3392] Chandra, R. and J. Scudder, "Capabilities Advertisement with BGP-4", RFC 3392, November 2002.

[RFC2918] Chen, E., "Route Refresh Capability for BGP-4", RFC 2918, September 2000.

[RFC3065] Traina, P., McPherson, D., and J. Scudder, "Autonomous System Confederations for BGP", RFC 3065, February 2001.

[RFC3562] Leech, M., "Key Management Considerations for the TCP MD5 Signature Option", RFC 3562, July 2003.

[IS10747] "Information Processing Systems - Telecommunications and Information Exchange between Systems - Protocol for Exchange of Inter-domain Routeing Information among Intermediate Systems to Support Forwarding of ISO 8473 PDUs", ISO/IEC IS10747, 1993.

[RFC4272] Murphy, S., "BGP Security Vulnerabilities Analysis", RFC 4272, January 2006