IANA Considerations (IANAに関する考慮事項)
IANA Considerations (IANAに関する考慮事項)
すべてのBGPメッセージには8ビットのメッセージタイプが含まれており、IANAは「BGP Message Types」という名前のレジストリを作成し、維持しています。このドキュメントでは、以下のメッセージタイプを定義しています:
| 名前 | 値 | 定義 |
|---|---|---|
| OPEN | 1 | セクション4.2を参照 |
| UPDATE | 2 | セクション4.3を参照 |
| NOTIFICATION | 3 | セクション4.5を参照 |
| KEEPALIVE | 4 | セクション4.4を参照 |
将来の割り当ては、[RFC2434]で定義されたStandards Actionプロセス、または[RFC4020]で定義されたEarly IANA Allocationプロセスを使用して行われます。割り当ては名前と値で構成されます。
BGP UPDATEメッセージは、1つ以上のパス属性を運ぶことができ、各属性には8ビットの属性タイプコードが含まれています。IANAは「BGP Path Attributes」という名前のそのようなレジストリをすでに維持しています。このドキュメントでは、以下のパス属性タイプコードを定義しています:
| 名前 | 値 | 定義 |
|---|---|---|
| ORIGIN | 1 | セクション5.1.1を参照 |
| AS_PATH | 2 | セクション5.1.2を参照 |
| NEXT_HOP | 3 | セクション5.1.3を参照 |
| MULTI_EXIT_DISC | 4 | セクション5.1.4を参照 |
| LOCAL_PREF | 5 | セクション5.1.5を参照 |
| ATOMIC_AGGREGATE | 6 | セクション5.1.6を参照 |
| AGGREGATOR | 7 | セクション5.1.7を参照 |
将来の割り当ては、[RFC2434]で定義されたStandards Actionプロセス、または[RFC4020]で定義されたEarly IANA Allocationプロセスを使用して行われます。割り当ては名前と値で構成されます。
BGP NOTIFICATIONメッセージは、8ビットのエラーコードを運び、IANAは「BGP Error Codes」という名前のレジストリを作成し、維持しています。このドキュメントでは、以下のエラーコードを定義しています:
| 名前 | 値 | 定義 |
|---|---|---|
| Message Header Error | 1 | セクション6.1 |
| OPEN Message Error | 2 | セクション6.2 |
| UPDATE Message Error | 3 | セクション6.3 |
| Hold Timer Expired | 4 | セクション6.5 |
| Finite State Machine Error | 5 | セクション6.6 |
| Cease | 6 | セクション6.7 |
将来の割り当ては、[RFC2434]で定義されたStandards Actionプロセス、または[RFC4020]で定義されたEarly IANA Allocationプロセスを使用して行われます。割り当ては名前と値で構成されます。
BGP NOTIFICATIONメッセージは、8ビットのエラーサブコードを運び、各サブコードは特定のエラーコードのコンテキスト内で定義されなければならず、したがってそのコンテキスト内でのみ一意である必要があります。
IANAは、各BGPエラーコードに対して個別のレジストリを持つ「Error Subcodes」というレジストリのセットを作成し、維持しています。将来の割り当ては、[RFC2434]で定義されたStandards Actionプロセス、または[RFC4020]で定義されたEarly IANA Allocationプロセスを使用して行われます。割り当ては名前と値で構成されます。
このドキュメントでは、以下のMessage Header Errorサブコードを定義しています:
| 名前 | 値 | 定義 |
|---|---|---|
| Connection Not Synchronized | 1 | セクション6.1を参照 |
| Bad Message Length | 2 | セクション6.1を参照 |
| Bad Message Type | 3 | セクション6.1を参照 |
このドキュメントでは、以下のOPEN Message Errorサブコードを定義しています:
| 名前 | 値 | 定義 |
|---|---|---|
| Unsupported Version Number | 1 | セクション6.2を参照 |
| Bad Peer AS | 2 | セクション6.2を参照 |
| Bad BGP Identifier | 3 | セクション6.2を参照 |
| Unsupported Optional Parameter | 4 | セクション6.2を参照 |
| [非推奨] | 5 | 付録Aを参照 |
| Unacceptable Hold Time | 6 | セクション6.2を参照 |
このドキュメントでは、以下のUPDATE Message Errorサブコードを定義しています:
| 名前 | 値 | 定義 |
|---|---|---|
| Malformed Attribute List | 1 | セクション6.3を参照 |
| Unrecognized Well-known Attribute | 2 | セクション6.3を参照 |
| Missing Well-known Attribute | 3 | セクション6.3を参照 |
| Attribute Flags Error | 4 | セクション6.3を参照 |
| Attribute Length Error | 5 | セクション6.3を参照 |
| Invalid ORIGIN Attribute | 6 | セクション6.3を参照 |
| [非推奨] | 7 | 付録Aを参照 |
| Invalid NEXT_HOP Attribute | 8 | セクション6.3を参照 |
| Optional Attribute Error | 9 | セクション6.3を参照 |
| Invalid Network Field | 10 | セクション6.3を参照 |
| Malformed AS_PATH | 11 | セクション6.3を参照 |
[RFC791] Postel, J., "Internet Protocol", STD 5, RFC 791, September 1981.
[RFC793] Postel, J., "Transmission Control Protocol", STD 7, RFC 793, September 1981.
[RFC2119] Bradner, S., "Key words for use in RFCs to Indicate Requirement Levels", BCP 14, RFC 2119, March 1997.
[RFC2385] Heffernan, A., "Protection of BGP Sessions via the TCP MD5 Signature Option", RFC 2385, August 1998.
[RFC904] Mills, D., "Exterior Gateway Protocol formal specification", RFC 904, April 1984.
[RFC1092] Rekhter, J., "EGP and policy based routing in the new NSFNET backbone", RFC 1092, February 1989.
[RFC1093] Braun, H., "NSFNET routing architecture", RFC 1093, February 1989.
[RFC1105] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol (BGP)", RFC 1105, June 1989.
[RFC1163] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol (BGP)", RFC 1163, June 1990.
[RFC1267] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol 3 (BGP-3)", RFC 1267, October 1991.
[RFC1771] Rekhter, Y. and T. Li, "A Border Gateway Protocol 4 (BGP- 4)", RFC 1771, March 1995.
[RFC1772] Rekhter, Y. and P. Gross, "Application of the Border Gateway Protocol in the Internet", RFC 1772, March 1995.
[RFC1518] Rekhter, Y. and T. Li, "An Architecture for IP Address Allocation with CIDR", RFC 1518, September 1993.
[RFC1519] Fuller, V., Li, T., Yu, J., and K. Varadhan, "Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy", RFC 1519, September 1993.
[RFC1930] Hawkinson, J. and T. Bates, "Guidelines for creation, selection, and registration of an Autonomous System (AS)", BCP 6, RFC 1930, March 1996.
[RFC1997] Chandra, R., Traina, P., and T. Li, "BGP Communities Attribute", RFC 1997, August 1996.
[RFC2439] Villamizar, C., Chandra, R., and R. Govindan, "BGP Route Flap Damping", RFC 2439, November 1998.
[RFC2474] Nichols, K., Blake, S., Baker, F., and D. Black, "Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers", RFC 2474, December 1998.
[RFC2796] Bates, T., Chandra, R., and E. Chen, "BGP Route Reflection - An Alternative to Full Mesh IBGP", RFC 2796, April 2000.
[RFC2858] Bates, T., Rekhter, Y., Chandra, R., and D. Katz, "Multiprotocol Extensions for BGP-4", RFC 2858, June 2000.
[RFC3392] Chandra, R. and J. Scudder, "Capabilities Advertisement with BGP-4", RFC 3392, November 2002.
[RFC2918] Chen, E., "Route Refresh Capability for BGP-4", RFC 2918, September 2000.
[RFC3065] Traina, P., McPherson, D., and J. Scudder, "Autonomous System Confederations for BGP", RFC 3065, February 2001.
[RFC3562] Leech, M., "Key Management Considerations for the TCP MD5 Signature Option", RFC 3562, July 2003.
[IS10747] "Information Processing Systems - Telecommunications and Information Exchange between Systems - Protocol for Exchange of Inter-domain Routeing Information among Intermediate Systems to Support Forwarding of ISO 8473 PDUs", ISO/IEC IS10747, 1993.
[RFC4272] Murphy, S., "BGP Security Vulnerabilities Analysis", RFC 4272, January 2006