跳到主要内容

IANA 考虑

IANA 考虑 (IANA Considerations)​

所有 BGP 消息都包含一个 8 比特消息类型 (message type), IANA 已为其创建并维护名为 "BGP Message Types" 的注册表 (registry). 本文档定义以下消息类型:

Name值定义
OPEN1见 Section 4.2
UPDATE2见 Section 4.3
NOTIFICATION3见 Section 4.5
KEEPALIVE4见 Section 4.4

未来分配通过 [RFC2434] 中定义的 Standards Action 流程, 或 [RFC4020] 中定义的 Early IANA Allocation 流程进行. 分配由名称和值组成.

BGP UPDATE 消息可以携带一个或多个路径属性 (path attribute), 每个属性都包含一个 8 比特属性类型代码 (Attribute Type Code). IANA 已维护一个名为 "BGP Path Attributes" 的此类注册表. 本文档定义以下路径属性类型代码:

Name值定义
ORIGIN1见 Section 5.1.1
AS_PATH2见 Section 5.1.2
NEXT_HOP3见 Section 5.1.3
MULTI_EXIT_DISC4见 Section 5.1.4
LOCAL_PREF5见 Section 5.1.5
ATOMIC_AGGREGATE6见 Section 5.1.6
AGGREGATOR7见 Section 5.1.7

未来分配通过 [RFC2434] 中定义的 Standards Action 流程, 或 [RFC4020] 中定义的 Early IANA Allocation 流程进行. 分配由名称和值组成.

BGP NOTIFICATION 消息携带一个 8 比特错误代码 (Error Code), IANA 已为其创建并维护名为 "BGP Error Codes" 的注册表. 本文档定义以下错误代码:

Name值定义
Message Header Error1Section 6.1
OPEN Message Error2Section 6.2
UPDATE Message Error3Section 6.3
Hold Timer Expired4Section 6.5
Finite State Machine Error5Section 6.6
Cease6Section 6.7

未来分配通过 [RFC2434] 中定义的 Standards Action 流程, 或 [RFC4020] 中定义的 Early IANA Allocation 流程进行. 分配由名称和值组成.

BGP NOTIFICATION 消息携带一个 8 比特错误子码 (Error Subcode), 每个子码必须在特定错误代码的上下文中定义, 因此只需在该上下文中唯一.

IANA 已创建并维护一组名为 "Error Subcodes" 的 registry, 每个 BGP error code 对应一个独立 registry. 未来分配通过 [RFC2434] 中定义的 Standards Action 流程, 或 [RFC4020] 中定义的 Early IANA Allocation 流程进行. 分配由名称和值组成.

本文档定义以下消息头错误 (Message Header Error) 子码:

Name值定义
Connection Not Synchronized1见 Section 6.1
Bad Message Length2见 Section 6.1
Bad Message Type3见 Section 6.1

本文档定义以下 OPEN Message Error subcode:

Name值定义
Unsupported Version Number1见 Section 6.2
Bad Peer AS2见 Section 6.2
Bad BGP Identifier3见 Section 6.2
Unsupported Optional Parameter4见 Section 6.2
[Deprecated]5见 Appendix A
Unacceptable Hold Time6见 Section 6.2

本文档定义以下 UPDATE Message Error subcode:

Name值定义
Malformed Attribute List1见 Section 6.3
Unrecognized Well-known Attribute2见 Section 6.3
Missing Well-known Attribute3见 Section 6.3
Attribute Flags Error4见 Section 6.3
Attribute Length Error5见 Section 6.3
Invalid ORIGIN Attribute6见 Section 6.3
[Deprecated]7见 Appendix A
Invalid NEXT_HOP Attribute8见 Section 6.3
Optional Attribute Error9见 Section 6.3
Invalid Network Field10见 Section 6.3
Malformed AS_PATH11见 Section 6.3

[RFC791] Postel, J., "Internet Protocol", STD 5, RFC 791, September 1981.

[RFC793] Postel, J., "Transmission Control Protocol", STD 7, RFC 793, September 1981.

[RFC2119] Bradner, S., "Key words for use in RFCs to Indicate Requirement Levels", BCP 14, RFC 2119, March 1997.

[RFC2385] Heffernan, A., "Protection of BGP Sessions via the TCP MD5 Signature Option", RFC 2385, August 1998.

[RFC904] Mills, D., "Exterior Gateway Protocol formal specification", RFC 904, April 1984.

[RFC1092] Rekhter, J., "EGP and policy based routing in the new NSFNET backbone", RFC 1092, February 1989.

[RFC1093] Braun, H., "NSFNET routing architecture", RFC 1093, February 1989.

[RFC1105] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol (BGP)", RFC 1105, June 1989.

[RFC1163] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol (BGP)", RFC 1163, June 1990.

[RFC1267] Lougheed, K. and Y. Rekhter, "Border Gateway Protocol 3 (BGP-3)", RFC 1267, October 1991.

[RFC1771] Rekhter, Y. and T. Li, "A Border Gateway Protocol 4 (BGP- 4)", RFC 1771, March 1995.

[RFC1772] Rekhter, Y. and P. Gross, "Application of the Border Gateway Protocol in the Internet", RFC 1772, March 1995.

[RFC1518] Rekhter, Y. and T. Li, "An Architecture for IP Address Allocation with CIDR", RFC 1518, September 1993.

[RFC1519] Fuller, V., Li, T., Yu, J., and K. Varadhan, "Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy", RFC 1519, September 1993.

[RFC1930] Hawkinson, J. and T. Bates, "Guidelines for creation, selection, and registration of an Autonomous System (AS)", BCP 6, RFC 1930, March 1996.

[RFC1997] Chandra, R., Traina, P., and T. Li, "BGP Communities Attribute", RFC 1997, August 1996.

[RFC2439] Villamizar, C., Chandra, R., and R. Govindan, "BGP Route Flap Damping", RFC 2439, November 1998.

[RFC2474] Nichols, K., Blake, S., Baker, F., and D. Black, "Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers", RFC 2474, December 1998.

[RFC2796] Bates, T., Chandra, R., and E. Chen, "BGP Route Reflection - An Alternative to Full Mesh IBGP", RFC 2796, April 2000.

[RFC2858] Bates, T., Rekhter, Y., Chandra, R., and D. Katz, "Multiprotocol Extensions for BGP-4", RFC 2858, June 2000.

[RFC3392] Chandra, R. and J. Scudder, "Capabilities Advertisement with BGP-4", RFC 3392, November 2002.

[RFC2918] Chen, E., "Route Refresh Capability for BGP-4", RFC 2918, September 2000.

[RFC3065] Traina, P., McPherson, D., and J. Scudder, "Autonomous System Confederations for BGP", RFC 3065, February 2001.

[RFC3562] Leech, M., "Key Management Considerations for the TCP MD5 Signature Option", RFC 3562, July 2003.

[IS10747] "Information Processing Systems - Telecommunications and Information Exchange between Systems - Protocol for Exchange of Inter-domain Routeing Information among Intermediate Systems to Support Forwarding of ISO 8473 PDUs", ISO/IEC IS10747, 1993.

[RFC4272] Murphy, S., "BGP Security Vulnerabilities Analysis", RFC 4272, January 2006