Aller au contenu principal

Appendix B. Comparison with RFC 1267 (Annexe B. Comparaison avec RFC 1267)

Appendix B. Comparison with RFC 1267 (Annexe B. Comparaison avec RFC 1267)​

Tous les changements listés dans l'Annexe A, plus ce qui suit.

BGP-4 est capable de fonctionner dans un environnement où un ensemble de destinations atteignables peut être exprimé via un seul préfixe IP. Le concept de classes de réseau ou de sous-réseautage est étranger à BGP-4. Pour accommoder ces capacités, BGP-4 modifie la sémantique et l'encodage associés à l'attribut AS_PATH. Un nouveau texte a été ajouté pour définir la sémantique associée aux préfixes IP. Ces capacités permettent à BGP-4 de supporter le schéma de supernetting proposé [RFC1518, RFC1519].

Pour simplifier la configuration, cette version introduit un nouvel attribut, LOCAL_PREF, qui facilite les procédures de sélection de routes.

L'attribut INTER_AS_METRIC a été renommé en MULTI_EXIT_DISC.

Un nouvel attribut, ATOMIC_AGGREGATE, a été introduit pour s'assurer que certains agrégats ne sont pas désagrégés. Un autre nouvel attribut, AGGREGATOR, peut être ajouté aux routes agrégées pour annoncer quel AS et quel haut-parleur BGP au sein de cet AS a causé l'agrégation.

Pour s'assurer que les temporisateurs de maintien sont symétriques, le temporisateur de maintien est maintenant négocié par connexion. Les temporisateurs de maintien de zéro sont maintenant supportés.