Passa al contenuto principale

Appendix D. Comparison with RFC 1105 (Appendice D. Confronto con RFC 1105)

Appendix D. Comparison with RFC 1105 (Appendice D. Confronto con RFC 1105)​

Tutte le modifiche elencate nelle Appendici A, B e C, più quanto segue.

Lievi modifiche alla macchina a stati finiti [RFC1105] erano necessarie per adattarsi all'interfaccia utente TCP fornita dalla versione 4.3 di BSD.

La nozione di relazioni Up/Down/Horizontal presentata in RFC 1105 è stata rimossa dal protocollo.

Le modifiche nel formato del messaggio rispetto a RFC 1105 sono le seguenti:

  1. Il campo Hold Time è stato rimosso dall'intestazione BGP e aggiunto al messaggio OPEN.

  2. Il campo versione è stato rimosso dall'intestazione BGP e aggiunto al messaggio OPEN.

  3. Il campo Link Type è stato rimosso dal messaggio OPEN.

  4. Il messaggio OPEN CONFIRM è stato eliminato e sostituito da una conferma implicita fornita dal messaggio KEEPALIVE.

  5. Il formato del messaggio UPDATE è stato modificato in modo significativo. Nuovi campi sono stati aggiunti al messaggio UPDATE per supportare più attributi di percorso.

  6. Il campo Marker è stato ampliato e il suo ruolo ampliato per supportare l'autenticazione.

Si noti che BGP, come specificato in RFC 1105, è spesso chiamato BGP-1; BGP, come specificato in [RFC1163], è chiamato BGP-2; BGP, come specificato in RFC 1267, è chiamato BGP-3; e BGP, come specificato in questo documento, è chiamato BGP-4.