3. 問題提起
Internationalizing Domain Names in Applications (IDNA) [RFC5890] は国際化ドメイン名を可能にするが,まだ大多数の利用者には普及していない.理由の 1 つは,命名方式全体がまだ国際化されていないことである.ドメイン名は,国際化が必要な多くの名前と識別子の 1 つにすぎず,他の識別子も国際化されるまで,国際化ドメイン名だけでは価値が限られる.
メールアドレスは,ドメイン名を国際化するだけでは十分ではない理由の主要な例である.ほとんどの観察者が経験から学んだように,ユーザーは,意义のない文字列や数字文字列を含むものよりも,名前や初期文字に似ているメールアドレスが大好きである.メールアドレス全体が熟知な文字やフォーマットを使用できない限り,ユーザーはメールを文化的に不友好なものとして認識する.メールアドレスで使用される名前や初期文字がユーザーの母語と文字システムで表現できれば,インターネットは特に母語がローマ系文字のサブセットで書かれていない者によってより自然に認識される.
メールアドレスの国際化は,SMTP envelope や From:, To:, Cc: ヘッダーフィールドを変更したり,MUA が特殊な符号化を復号して現地文字を表示したりするだけでは実現しない.アドレスが現れるすべての文脈で,一貫して国際化し処理する必要がある.個別のパッチや回避策の集合では不十分であり,実装ごとの差異が利用者を混乱させる.必要なのは,同じ言語と文字体系を共有する人々が効率よく通信できる,完全に国際化されたメール環境である.そのためには,適切なヘッダーフィールドで Unicode 全体を使えるようにし,UTF-8 [RFC3629] [RFC5198] のアドレスと拡張ヘッダーフィールドを配送できる SMTP 拡張,配送・サービス通知の国際化 [RFC3461] [RFC3464],および 8BITMIME SMTP 拡張 [RFC6152] のサポートが必要になる.