メインコンテンツまでスキップ

4. 用語

この文書は,RFC 5321 [RFC5321]およびRFC 5322 [RFC5322] で文書化されたコアメール標準のプロトコルと用語について合理的な理解を前提とする.

4.1. メールユーザーエージェントとメール転送エージェント​

本文書の多くは Mail Transfer Agent (MTA) と Mail User Agent (MUA) という抽象概念に依存する.ただし,これらの用語と概念は,インターネットメールのアーキテクチャ設計および「protocols on the wire」原則の適用より後に成立した.発展してきたメールアーキテクチャとこの原則のため,同一の送信元・宛先ホストで MTA と MUA がどう相互作用するか,あるいは別の構成要素かについて,強い標準化された区別はない.

しかし,この文書では"最終配信MTA"という用語は,RFC 5321の"配信システム"または"最終配信システム"という用語に相当する形で使用されています.これは SMTPサーバで,アドレスがローカルな部分のフォーマットを制御し,それらを検査し解釈することが許可されています.ネットワークからメッセージが送受信または他のローカル処理のために受信されます.転送を含む,またはリレーではなく封筒アドレスを変更するイラストまたはアライスします.ネットワークの観点から,メッセージストアに保存,特定のメッセージ配信プログラムまたはエージェントへの転送,およびメッセージの回収メカニズムなどのローカル配信の取り決めは,すべて最終的な配信MTAの"後ろ"であり,したがって SMTPまたは配信プロセスの一部ではありません.

4.2. アドレスの文字集合​

この文書では,アドレスが"All-ASCII"または単に"ASCII address"である.アドレス内のすべての文字がASCII文字レパートリー [ASCII] に含まれている場合;アドレスが"non-ASCII"または"i18n address"である. ASCII文字レパートリーに含まれていない場合.そのようなアドレスは他の方法で制限されるが,これらの制限はこの定義に関連していない.この区別が重要である場合,用語"All-ASCII"は他のプロトコル要素に適用され,その反対は"non-ASCII"または"国際化"である.

本文書と関連文書が規定するメールアドレス国際化の総称は SMTPUTF8 である.例えば,本仕様が許可するアドレスを「SMTPUTF8 適合アドレス」と呼ぶ.

ここで示された定義に従って",All-ASCII"アドレスセットと"Non-ASCII"アドレスセットは相互に除外されていることに注意してください. SMTPUTF8 が表示されるときに許可されるすべてのアドレスセットは,これらの2つのセットの結合です.

4.3. ユーザーの種類​

"ASCIIユーザー"は, (i) ASCII文字のみを含む電子メールアドレスを専用使用し, (ii) ASCII文字以外の文字を含む受信者のアドレスを生成することはできません.

「国際化メールユーザー」は,1 つ以上の non-ASCII メールアドレスを持つか,non-ASCII 文字を含む受信者アドレスを生成できる利用者である.ASCII アドレスを併用してもよい.複数のアカウント,対応アドレス,または同一アドレスの複数エイリアスを持つ場合,送信メールで使うアドレスを選ぶ手段を持つ.ASCII アドレスだけを見ても,所有者が国際化メールユーザーかは判断できない.non-ASCII アドレスなら,所有者が国際化メールユーザーであると推測できる.「国際化メールユーザーメッセージ」という概念はなく,この用語は利用者とそのエージェントおよび能力だけに適用する.non-ASCII のメッセージ内容は MIME [RFC2045] の一部であり,本拡張を必要としない.

4.4. メッセージ​

"メッセージ"は,特定の電子メールアドレスを使用して,あるユーザー (送信者) から,受信者の電子メールアドレス (しばしば"ユーザー"または"受信者ユーザー"と呼ばれている) に送信されます.

4.5. メーリングリスト​

「メーリングリスト」は,1 つの受信者アドレスへ送ったメッセージを複数の対象受信者へ配布する仕組みである.その単一アドレスのエージェント (通常は人ではない) が再配布を行い,再配布メッセージの envelope return address (reverse-path) を元の受信者アドレスとは別のアドレスに設定する.これにより,エラーなどの自動生成メッセージはエラー処理用アドレスへ送られる.

ASCII以外のアドレスを含むメールリストを管理するための特別な規定は,そのテーマに特化した文書 [RFC5983]およびその予期される後継者 [RFC5983bis-MailingList] で議論されています.

4.6. 従来型メッセージと国際化メッセージ​

  • 標準メッセージは,SMTP拡張文書 [RFC6531] または UTF8header文書 [RFC6532] で定義された拡張を使用していないもので,この仕様セットで厳密にRFC 5322 [RFC5322] に準拠している.

  • 国際化メッセージは,この仕様セットで定義された拡張機能の1つまたは複数のものを利用したメッセージであり,もはや電子メールメッセージの伝統的な仕様やその輸送に適合していない.

4.7. 配信不能メッセージ、通知、配信確認​

RFC 5321 に規定されているように,何らかの理由で送受信できないメッセージは送信者に通知される.これは2つの方法いずれかで発生する可能性があります.通常"拒否"と呼ばれる SMTP サーバが致命的なエラーを表示する応答コード (5yz"コード) を返還するときに発生します.または一時的な故障エラー (4yz"コード) を持続的に返還します. SMTP 処理中にメッセージを受け入れ,その後送信者にメッセージを生成します.通常は"送受信しない通知"または"NDN"として知られています.現在の慣習は,NDNの生成がスパミング技術として使用される可能性が低下しているため,NDNの生成がNDNに拒否されるのを好む.後者,NDN,次の間接サーバーが拒否するメッセージが受け入れられれば避けられない.

送信者は,これらの国際化拡張について NDN と同じ問題を生じるメッセージ受領通知 [RFC3461] を明示的に要求してもよい (MAY).