メインコンテンツまでスキップ

13. セキュリティに関する考慮事項

メールアドレスに許可された文字や暗号化フォームの拡張は,いくつかのリスクを伴う.いわゆる"IDN-spoofing"または"IDN homograph attacks"に関する議論が行われた.これらの攻撃は,攻撃者が (または"phisher") が企業または他のエンティティのドメインまたはURLを偽造することを可能にする.同じタイプの攻撃は,国際化されたメールアドレスのローカル部分にも可能である.提案された修正は,すべての表示された要素を標準化された小文字で表示することを含むことを注意すべきです. URLのドメイン名については,URLのローカル部分には対応しません.

メールアドレスがしばしばビスケットカードや紙上のメモから書き換えられているため,混乱した文字から生じる問題にも晒されている (RFC4690参照).メールボックスに関連したドメインが曖昧で,名前が地元のシステム慣習に従う比較的少数のメールボックスをサポートする場合,これらの問題は少し軽減されます.ユーザーは自由に自分のアドレスを選択できる非常に大きなメールシステムにより,それらの名前が増加します.

メールアドレスとメッセージヘッダの国際化により,必要な拡張機能がなければインターネットが安全性が低下させてはならない.この仕様セットに記載されている要件とメカニズムは,一般的に,新しいセキュリティ問題を引き起こすものではない.

混同文字に関連する問題に関するレビューが必要である.他の場所で徹底的に調査されているテーマ (例えば,RFC 4690 [RFC4690]) - そして,RFC 3629 [RFC3629] で議論されている UTF-8 標準化に関する問題や他の変換に関する問題がある. 標準化および変換と標準形式に関連するその他の問題は,他の場所で説明されている作業のテーマの一部である [RFC5198] [RFC5893] [RFC6055].

国際化アドレスとメッセージヘッダに関連するいくつかの問題は,このセットの他の文書でより詳細に議論されています.しかし,特に",ダウングレード"メカニズム,またはダウングレードのアドレスの使用は,国際化およびASCIIアドレス間の認証された結合を不適切に想定しないことを注意する必要があります.この潜在的な問題は,送信ユーザーの管理管理管理下にあるものではなく,送信ユーザーの管理管理下にあると考えられるシステムによって最終配信前にほとんどのまたはすべてのそのような変換が実行されるという期待を強制することによって,少し緩和することができます.

新しい UTF-8 ヘッダーとメッセージフォーマットは,別の既知の問題を引き起こすか悪化させる可能性があります.モデルが"無効"または"不正な"メッセージの新しい形態を作成した場合,新しい電子メール攻撃が作成されます.強固になるため,一部のエージェントまたはほとんどのエージェントはそのようなメッセージを受け入れ,それらを適切にフォーマットしたかのように解釈します.フィルターが受信者が使用するMUAとは異なるメッセージを解釈した場合,フィルターの解釈では受け入れられるように見えるメッセージを作成することが可能になるが,その MUAによって与えられた解釈の下で拒絶されるべきです.そのような攻撃は既存のメッセージやエンコーディングレイヤー,例えば無効なMIME構文,無効なHTMLマークアップ,特定の画像タイプの無効なコーディングなどで既に発生しています.

また,電子メールアドレスはメールを送信以外の多くの文脈で使用されます (例えば,様々な状況下で識別子 (第11.2節を参照). これらの文脈それぞれが評価され,ASCII以外のフォームの使用が適切か,どのような特定の問題を提起するか判断する必要があります.

この作業は,メールヘッダーのデジタル署名などの完全性保護に依存するシステムへ明らかに影響する (11.3 節).PGP と S/MIME の従来の多くの用途は本文部分を署名しヘッダーを署名しないため影響を受けない.一方,DomainKeys Identified Mail (DKIM) [RFC5863] と本仕様は相互に考慮する必要がある.本文書は DKIM などの署名付きヘッダー機構が提起する問題を解決しないが,両者が共存するには調整が必要である.PKI 証明書 [RFC5280] にメールアドレスを含める場合も,国際化アドレスと紛らわしい文字による偽装へ対応するよう関連標準を更新する必要がある.