Aller au contenu principal

6. Bilan des résultats expérimentaux

La différence clé entre ce jeu de protocoles et le jeu expérimental qui les a précédés [RFC5335] [RFC5336] [RFC5337] [RFC5504] [RFC5721] [RFC5738] [RFC5825] est que le groupe antérieur a fourni un mécanisme de dégradation de messages en transit (décrit en détail dans RFC 5504). Ce mécanisme a permis et exigé essentiellement que chaque adresse non ASCII soit accompagnée d'un équivalent ASCII. Cela a, à son tour, soulevé des inquiétudes de sécurité associées à l'association d'adresses qui ne pouvaient pas être authentifiées. Après avoir examiné l'expérience acquise avec les précédents, expérimentaux et prédécesseurs de ces spécifications, le groupe de travail qui les a élaborées a conclu que les avantages de la dégradation du niveau de transit, s'il était opérationnellement possible, seraient suffisamment importants pour surmonter ces préoccupations.

Avant de commencer les travaux qui ont conduit à ce jeu de spécifications, le GW a conclu que la combinaison des exigences et des implications à long terme de ce modèle antérieur était trop complexe pour être satisfaisante et que les travaux devaient aller de l'avant sans lui.

L'autre changement important apporté aux protocoles eux-mêmes est que le mot clé SMTPUTF8 est désormais requis comme annonce client SMTP si l'extension est nécessaire; dans la version expérimentale, seule l'annonce du serveur selon laquelle une enveloppe et/ou un contenu étendu étaient autorisés était nécessaire.