Zum Hauptinhalt springen

6. Überprüfung der experimentellen Ergebnisse

Der wesentliche Unterschied zwischen dieser Protokollgruppe und der experimentellen Gruppe, die ihnen vorausging [RFC5335] [RFC5336] [RFC5337] [RFC5504] [RFC5721] [RFC5738] [RFC5825], besteht darin, dass die frühere Gruppe einen Mechanismus für das Downgrading von Nachrichten während der Übertragung bereitstellte (im Detail in RFC 5504 beschrieben). Dieser Mechanismus erlaubte und erforderte im Wesentlichen, dass jede non-ASCII-Adresse von einem all-ASCII-Äquivalent begleitet wird. Das wiederum warf Sicherheitsbedenken im Zusammenhang mit der Paarung von Adressen auf, die nicht authentifiziert werden konnten. Es führte auch die erste inkompatible Änderung der Internet-Mail-Adressierung seit vielen Jahren ein, was Bedenken hinsichtlich Interoperabilitätsproblemen aufwarf, falls die neuen Adressformen in Legacy-E-Mail-Implementierungen "durchsickern" würden. Nach der Untersuchung der Erfahrungen mit den früheren, experimentellen Vorgängern dieser Spezifikationen kam die Arbeitsgruppe, die sie hervorbrachte, zu dem Schluss, dass die Vorteile des Downgradings während der Übertragung, wäre es operativ machbar, bedeutend genug wären, um diese Bedenken zu überwinden.

Das stellte sich als nicht zutreffend heraus, mit Interoperabilitätsproblemen unter den ersten Implementierungen. Vor Beginn der Arbeit, die zu dieser Spezifikationsgruppe führte, kam die WG zu dem Schluss, dass die Kombination aus Anforderungen und langfristigen Implikationen jenes früheren Modells zu komplex war, um zufriedenstellend zu sein, und dass die Arbeit ohne es fortgesetzt werden sollte.

Die andere bedeutende Änderung an den Protokollen selbst besteht darin, dass das Schlüsselwort SMTPUTF8 nun als SMTP-Client-Ankündigung erforderlich ist, wenn die Erweiterung benötigt wird; in der experimentellen Version war nur die Server-Ankündigung erforderlich, dass ein erweiterter Umschlag und/oder Inhalt erlaubt sei.