Passa al contenuto principale

6. Revisione dei risultati sperimentali

La differenza chiave tra questo insieme di protocolli e l'insieme sperimentale che li ha preceduti [RFC5335] [RFC5336] [RFC5337] [RFC5504] [RFC5721] [RFC5738] [RFC5825] è che il gruppo precedente forniva un meccanismo per il downgrading dei messaggi in transito (descritto in dettaglio nell'RFC 5504). Quel meccanismo consentiva, e in sostanza richiedeva, che ogni indirizzo non-ASCII fosse accompagnato da un equivalente all-ASCII. Ciò, a sua volta, sollevava problemi di sicurezza associati all'abbinamento di indirizzi che non potevano essere autenticati. Introduceva inoltre il primo cambiamento incompatibile all'indirizzamento della posta Internet in molti anni, sollevando preoccupazioni circa problemi di interoperabilità qualora le nuove forme di indirizzo "trapelassero" in implementazioni email legacy. Dopo aver esaminato l'esperienza con i predecessori sperimentali di queste specifiche, il gruppo di lavoro che le ha prodotte concluse che i vantaggi del downgrading in transito, se fosse stato operativamente fattibile, sarebbero stati sufficientemente significativi da superare tali preoccupazioni.

Ciò si rivelò non essere il caso, con problemi di interoperabilità tra le implementazioni iniziali. Prima di iniziare il lavoro che ha portato a questo insieme di specifiche, il WG concluse che la combinazione di requisiti e implicazioni a lungo termine di quel modello precedente era troppo complessa per essere soddisfacente e che il lavoro dovesse procedere senza di esso.

L'altra modifica significativa ai protocolli stessi è che la parola chiave SMTPUTF8 è ora richiesta come annuncio del client SMTP se l'estensione è necessaria; nella versione sperimentale era necessario solo l'annuncio del server che una busta estesa e/o un contenuto esteso erano consentiti.