Zum Hauptinhalt springen

5. Überblick über den Ansatz und Dokumentplan

Diese Spezifikationsgruppe ändert sowohl SMTP als auch die Zeichenkodierung von E-Mail-Nachrichtenheadern, um non-ASCII-Zeichen direkt darstellen zu können. Jede wichtige Komponente der Arbeit wird in einem separaten Dokument beschrieben. Das Dokumentensemble, dessen Mitglieder unten beschrieben werden, enthält auch Informational-Dokumente, deren Zweck darin besteht, Implementierungsvorschläge und Leitlinien für die Protokolle bereitzustellen.

Zusätzlich zu diesem Dokument bilden die folgenden Dokumente diese Spezifikation und bieten Ratschläge und Kontext dafür.

  • SMTP-Erweiterung. Das SMTP-Erweiterungsdokument [RFC6531] stellt eine SMTP-Erweiterung (wie in RFC 5321 vorgesehen) für internationalisierte Adressen bereit.

  • E-Mail-Nachrichtenheader in UTF-8. Das E-Mail-Nachrichtenheader-Dokument [RFC6532] aktualisiert im Wesentlichen RFC 5322, um zuzulassen, dass einige Informationen in E-Mail-Nachrichtenheadern direkt durch in UTF-8 kodierte Unicode-Zeichen ausgedrückt werden, wenn die oben beschriebene SMTP-Erweiterung verwendet wird. Dieses Dokument, möglicherweise zusammen mit einem oder mehreren ergänzenden Dokumenten, wird sich auch mit den Wechselwirkungen mit MIME befassen müssen, einschließlich der Beziehungen zwischen SMTPUTF8 und internen MIME-Headern und Inhaltstypen.

  • Erweiterungen für die Behandlung von Zustellstatus und Benachrichtigungen, um sich an internationalisierte Adressen anzupassen [RFC6533].

  • Kommende Dokumente werden Erweiterungen des IMAP-Protokolls [RFC3501] zur Unterstützung internationalisierter Nachrichtenheader [RFC5738bis-IMAP], parallele Erweiterungen des POP-Protokolls [RFC5721] [RFC5721bis-POP3] und einige gemeinsame Eigenschaften der beiden [POPIMAP-downgrade] spezifizieren.