1. 背景と使用目的
X.500 ベースのディレクトリシステム [X.500] では、Lightweight Directory Access Protocol (LDAP) [RFC4510] を使ってアクセスされるものを含め、識別名 (DN) はディレクトリエントリを曖昧さなく参照するために用いられる [X.501][RFC4512]。
DN [X.501] の構造は ASN.1 [X.680] で記述される。X.500 ディレクトリアクセスプロトコル [X.511](およびその他の ITU 定義のディレクトリプロトコル)では、DN は基本符号化規則 (BER) [X.690] を使って符号化される。LDAP では、DN は本ドキュメントで記述される文字列形式で表現される。
識別名を曖昧さなく表現できる共通の形式を持つことは重要である。本仕様の第一の目標は符号化と復号の容易さであり、第二の目標は人が読める名前にすることである。人間向けのユーザインタフェースを持つ LDAP 実装がこれらの文字列を直接ユーザに表示するとは想定されておらず、ほとんどの場合は変換(たとえば属性型名をローカルの国語で表現するなど)を行うと考えられる。
本ドキュメントは LDAP [RFC4511][RFC4517] で使用される識別名の文字列表現を定義する。第 2 節は DN を ASN.1 構造表現から文字列に変換する推奨 (RECOMMENDED) アルゴリズムを詳述する。第 3 節は DN を文字列から ASN.1 構造表現に変換する方法を詳述する。
他のドキュメントが DN を ASN.1 構造表現から文字列に変換する別のアルゴリズムを定義してもよいが、すべてのアルゴリズムは第 3 節の要件に適合する文字列を生成しなければならない (MUST)。
本ドキュメントは DN の正規化された文字列表現を定義しない。DN の等価比較は distinguishedNameMatch マッチング規則 [RFC4517] に従って行われる。
本ドキュメントは LDAP 技術仕様 [RFC4510] の不可分の一部であり、同仕様は以前に定義された LDAP 技術仕様 RFC 3377 を全体として廃止する。本ドキュメントは RFC 2253 を廃止する。RFC 2253 からの変更点は付録 B にまとめられている。
本仕様は X.500 [X.500] および識別名 [X.501][RFC4512] の概念に精通していることを前提とする。
1.1. 表記規約
本ドキュメントにおけるキーワード "MUST"、"MUST NOT"、"REQUIRED"、"SHALL"、"SHALL NOT"、"SHOULD"、"SHOULD NOT"、"RECOMMENDED"、"MAY"、および "OPTIONAL" は、BCP 14 [RFC2119] に記述されるとおりに解釈される。
本ドキュメントにおける文字名は、Unicode 標準 [Unicode] のコードポイントと名称の記法を用いる。たとえば、文字 "a" は <U+0061> または
注:Unicode で用いられる用語集は [Glossary] にある。Unicode 文字符号化モデルに関する情報は [CharModel] にある。