1. Contesto e uso previsto
Nei sistemi di directory basati su X.500 [X.500], compresi quelli a cui si accede tramite il Lightweight Directory Access Protocol (LDAP) [RFC4510], i nomi distinti (DN) sono utilizzati per riferirsi in modo inequivocabile alle voci della directory [X.501][RFC4512].
La struttura di un DN [X.501] è descritta in ASN.1 [X.680]. Nel protocollo di accesso alla directory X.500 [X.511] (e in altri protocolli di directory definiti dall'ITU), i DN sono codificati utilizzando le Basic Encoding Rules (BER) [X.690]. In LDAP, i DN sono rappresentati nella forma di stringa descritta in questo documento.
Disporre di un formato comune per poter rappresentare in modo inequivocabile un nome distinto è importante. L'obiettivo primario di questa specifica è la facilità di codifica e decodifica. Un obiettivo secondario è avere nomi leggibili dall'uomo. Non ci si aspetta che le implementazioni LDAP dotate di interfaccia utente umana mostrino direttamente queste stringhe all'utente, ma che molto probabilmente effettuino traduzioni (ad esempio esprimendo i nomi dei tipi di attributo nella lingua nazionale locale).
Questo documento definisce la rappresentazione in formato stringa dei Distinguished Name utilizzata in LDAP [RFC4511][RFC4517]. La sezione 2 descrive in dettaglio l'algoritmo raccomandato (RECOMMENDED) per convertire un DN dalla sua rappresentazione strutturata ASN.1 a una stringa. La sezione 3 descrive in dettaglio come convertire un DN da una stringa a una rappresentazione strutturata ASN.1.
Sebbene altri documenti possano definire altri algoritmi per convertire un DN dalla sua rappresentazione strutturata ASN.1 a una stringa, tutti gli algoritmi DEVONO (MUST) produrre stringhe conformi ai requisiti della sezione 3.
Questo documento non definisce una rappresentazione in formato stringa canonica per i DN. Il confronto di uguaglianza dei DN deve essere effettuato secondo la regola di corrispondenza distinguishedNameMatch [RFC4517].
Questo documento è parte integrante delle specifiche tecniche LDAP [RFC4510], che obsoletano integralmente la specifica tecnica LDAP precedentemente definita, la RFC 3377. Questo documento obsoleta la RFC 2253. Le modifiche rispetto alla RFC 2253 sono riassunte nell'appendice B.
Questa specifica presuppone familiarità con X.500 [X.500] e con il concetto di Distinguished Name [X.501][RFC4512].
1.1. Convenzioni
Le parole chiave "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" e "OPTIONAL" in questo documento devono essere interpretate come descritto nella BCP 14 [RFC2119].
I nomi dei caratteri in questo documento utilizzano la notazione per i punti di codice e i nomi dello standard Unicode [Unicode]. Ad esempio, la lettera "a" può essere rappresentata come <U+0061> oppure
Nota: un glossario dei termini utilizzati in Unicode è disponibile in [Glossary]. Informazioni sul modello di codifica dei caratteri Unicode sono disponibili in [CharModel].