跳到主要内容

1. 背景与使用意图

在基于 X.500 的目录系统 [X.500] 中(包括那些使用轻量级目录访问协议 (LDAP) [RFC4510] 访问的系统),可分辨名称 (DN) 被用来无歧义地指代目录条目 [X.501][RFC4512]。

DN [X.501] 的结构用 ASN.1 [X.680] 描述。在 X.500 目录访问协议 [X.511](以及其他 ITU 定义的目录协议)中,DN 使用基本编码规则 (BER) [X.690] 编码。在 LDAP 中,DN 以本文档描述的字符串形式表示。

拥有一种通用格式以便能够无歧义地表示一个可分辨名称,这一点很重要。本规范的主要目标是便于编码和解码,次要目标是让名称具有人类可读性。并不期望带有人工用户界面的 LDAP 实现把这些字符串直接显示给用户,它们更可能会进行转换(例如以本地民族语言表达属性类型名称)。

本文档定义 LDAP [RFC4511][RFC4517] 中使用的可分辨名称的字符串表示。第 2 节详述把 DN 从其 ASN.1 结构化表示转换为字符串的推荐 (RECOMMENDED) 算法。第 3 节详述如何把 DN 从字符串转换为 ASN.1 结构化表示。

虽然其他文档可以定义把 DN 从其 ASN.1 结构化表示转换为字符串的其他算法,但所有算法必须 (MUST) 产生符合第 3 节要求的字符串。

本文档不为 DN 定义规范化的字符串表示。DN 的相等比较应按照 distinguishedNameMatch 匹配规则 [RFC4517] 进行。

本文档是 LDAP 技术规范 [RFC4510] 的组成部分,该规范整体废弃了先前定义的 LDAP 技术规范 RFC 3377。本文档废弃 RFC 2253。相对 RFC 2253 的变更在附录 B 中汇总。

本规范假定读者熟悉 X.500 [X.500] 以及可分辨名称 [X.501][RFC4512] 的概念。

1.1. 约定​

本文档中的关键字 "MUST"、"MUST NOT"、"REQUIRED"、"SHALL"、"SHALL NOT"、"SHOULD"、"SHOULD NOT"、"RECOMMENDED"、"MAY" 和 "OPTIONAL" 应按 BCP 14 [RFC2119] 中的描述进行解释。

本文档中的字符名称采用 Unicode 标准 [Unicode] 中代码点和名称的记法。例如,字母 "a" 可以表示为 <U+0061> 或 。

注:Unicode 中所用术语的词汇表见 [Glossary]。有关 Unicode 字符编码模型的信息见 [CharModel]。