RFC 4515 - Lightweight Directory Access Protocol (LDAP): 検索フィルタの文字列表現
- ステータス: Proposed Standard
- 発行日: June 2006
- ストリーム: IETF
- 廃止: RFC2254
- エラッタ: エラッタなし
概要
Lightweight Directory Access Protocol (LDAP) 検索フィルタは、ネットワーク上での使用に適したバイナリ表現を使用して LDAP プロトコルで送信されます。本文書は、LDAP URL (RFC 4516) やその他のアプリケーションでの使用に適した、LDAP 検索フィルタの人間が読める文字列表現を定義します。
目次
- 1. はじめに
- 2. LDAP 検索フィルタの定義
- 3. 文字列検索フィルタの定義
- 4. 例
- 5. セキュリティに関する考慮事項
- 6. 引用規格
- 7. 参考文献
- 8. 謝辞
- 付録 A. RFC 2254 からの変更点 (Appendix A. Changes Since RFC 2254)
著者のアドレス
Mark Smith, Editor
Pearl Crescent, LLC
447 Marlpool Dr.
Saline, MI 48176
USA
Phone: +1 734 944-2856
EMail: [email protected]
Tim Howes
Opsware, Inc.
599 N. Mathilda Ave.
Sunnyvale, CA 94085
USA
Phone: +1 408 744-7509
EMail: [email protected]
完全な著作権声明
Copyright (C) The Internet Society (2006).
この文書は、BCP 78 に記載された権利、ライセンス、および制限の対象となり、そこに明記された場合を除き、著者はすべての権利を留保します。
この文書およびその内容は「現状有姿」で提供されます。投稿者、投稿者が代表するまたは投稿者を後援する組織 (ある場合)、インターネット協会、およびインターネット技術標準化委員会は、明示的または黙示的ないかなる保証も行わず、本文書の情報の使用がいかなる権利も侵害しないという保証や、特定目的に対する商品性または適合性の黙示の保証を含みます。
知的財産権
IETF は、本書に記載された技術の実装または使用に関連すると主張される知的財産権その他の権利の有効性または範囲、およびそのような権利に基づくライセンスがどの程度取得可能であるかについて、いかなる立場もとりません。また IETF は、そのような権利を識別するための独立した努力を行ったことも表明しません。RFC 文書に関連する権利の取り扱い手順については、BCP 78 および BCP 79 を参照してください。
IETF 事務局に対して行われた知的財産権の開示の写し、提供されるライセンスの保証、または実装者がそのような専用権の一般的なライセンスまたは権利許諾を取得しようとした結果は、IETF オンライン知的財産権リポジトリ http://www.ietf.org/ipr から入手できます。
IETF は、本標準の実装に必要な技術をカバーし得る著作権、特許、または特許出願、その他の専用権に注意を向けるよう、関連するすべての当事者に呼びかけています。関連情報は [email protected] まで送付してください。
謝辞
RFC Editor 機能の資金は、IETF Administrative Support Activity (IASA) によって提供されています。