RFC 4515 - Lightweight Directory Access Protocol (LDAP): Rappresentazione in stringa dei filtri di ricerca
- Stato: Proposed Standard
- Pubblicato: June 2006
- Stream: IETF
- Sostituisce: RFC2254
- Errata: Nessun errata
Sommario
I filtri di ricerca del Lightweight Directory Access Protocol (LDAP) vengono trasmessi nel protocollo LDAP utilizzando una rappresentazione binaria appropriata per l'uso sulla rete. Questo documento definisce una rappresentazione in stringa leggibile dall'uomo dei filtri di ricerca LDAP appropriata per l'uso negli URL LDAP (RFC 4516) e in altre applicazioni.
Indice
- 1. Introduzione
- 2. Definizione del filtro di ricerca LDAP
- 3. Definizione del filtro di ricerca in stringa
- 4. Esempi
- 5. Considerazioni sulla sicurezza
- 6. Riferimenti normativi
- 7. Riferimenti informativi
- 8. Ringraziamenti
- Appendice A. Modifiche dalla RFC 2254 (Appendix A. Changes Since RFC 2254)
Indirizzi degli autori
Mark Smith, Editor
Pearl Crescent, LLC
447 Marlpool Dr.
Saline, MI 48176
USA
Phone: +1 734 944-2856
EMail: [email protected]
Tim Howes
Opsware, Inc.
599 N. Mathilda Ave.
Sunnyvale, CA 94085
USA
Phone: +1 408 744-7509
EMail: [email protected]
Dichiarazione completa di copyright
Copyright (C) The Internet Society (2006).
Questo documento è soggetto ai diritti, alle licenze e alle restrizioni indicati nella BCP 78, e gli autori conservano tutti i loro diritti, salvo quanto espressamente previsto.
Questo documento e le informazioni in esso contenute sono forniti «così come sono». I contributori, l'organizzazione che rappresentano o che li patrocina (se applicabile), l'Internet Society e l'Internet Engineering Task Force non rilasciano alcuna garanzia, esplicita o implicita, ivi inclusa, senza limitazioni, qualsiasi garanzia che l'uso delle informazioni in questo documento non violi alcun diritto, o garanzie implicite di commerciabilità o idoneità a un particolare scopo.
Proprietà intellettuale
L'IETF non prende alcuna posizione circa la validità o l'ambito di eventuali diritti di proprietà intellettuale o altri diritti rivendicati come relativi all'implementazione o all'uso della tecnologia descritta in questo documento, e non fa alcuna dichiarazione che esso abbia intrapreso sforzi indipendenti per identificare tali diritti. Per la procedura di gestione dei diritti relativi ai documenti RFC, vedere la BCP 78 e la BCP 79.
Copie delle divulgazioni di proprietà intellettuale presentate al segretariato IETF, di qualsiasi garanzia di licenza fornita, o dei risultati ottenuti dagli implementatori che cercano di ottenere una licenza generale o un'autorizzazione all'uso di tali diritti esclusivi sono disponibili nel repository online della proprietà intellettuale IETF all'indirizzo http://www.ietf.org/ipr.
L'IETF invita tutte le parti interessate a portare alla sua attenzione eventuali copyright, brevetti o domande di brevetto, o altri diritti esclusivi che potrebbero coprire la tecnologia necessaria per implementare questo standard. Si prega di inviare le informazioni pertinenti a [email protected].
Ringraziamenti
Il finanziamento della funzione di RFC Editor è fornito dall'IETF Administrative Support Activity (IASA).