1. Introduction
Ce document définit une extension du protocole SMTP (Simple Mail Transfer Protocol) [RFC5321] afin que les serveurs puissent annoncer leur capacité à accepter et traiter des adresses électroniques internationalisées (voir section 1.1) et des en-têtes de courrier électronique internationalisés [RFC6532].
Une vue d'ensemble étendue du modèle d'extension pour les adresses électroniques internationalisées et l'en-tête de courrier électronique apparaît dans le RFC 6530 [RFC6530], désigné comme "le document cadre" dans cette spécification. Une compréhension approfondie des informations contenues dans ce document et dans les spécifications de base du courrier électronique Internet [RFC5321] [RFC5322] est nécessaire pour comprendre et mettre en œuvre cette spécification.
1.1. Terminologie
Les mots clés "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" et "OPTIONAL" dans ce document doivent être interprétés comme décrit dans le RFC 2119 [RFC2119].
Les termes "chaîne UTF-8" ou "caractère UTF-8" sont utilisés pour faire référence aux caractères Unicode, qui peuvent ou non être membres du sous-ensemble ASCII, en UTF-8 [RFC3629], une forme de codage Unicode standard. Tous les autres termes spécialisés utilisés dans cette spécification sont définis dans le document cadre ou dans les spécifications de base du courrier électronique Internet. En particulier, les termes "adresse ASCII", "adresse électronique internationalisée", "adresse non ASCII", "SMTPUTF8", "message internationalisé" et "message" sont utilisés dans ce document conformément aux définitions du document cadre [RFC6530].
Les chaînes mentionnées dans ce document, y compris les chaînes ASCII, DOIVENT être exprimées en UTF-8.
Cette spécification utilise les règles de la BNF augmentée (ABNF) [RFC5234]. Certaines règles de base de ce document sont identifiées dans la section 3.3 comme étant définies (sous les mêmes noms) dans le RFC 5234 [RFC5234], le RFC 5321 [RFC5321], le RFC 5890 [RFC5890] ou le RFC 6532 [RFC6532].
1.2. Modifications apportées à d'autres spécifications
Cette spécification étend certaines règles de syntaxe définies dans le RFC 5321 et permet les adresses électroniques internationalisées dans l'enveloppe et dans les champs de trace, mais elle ne modifie pas le RFC 5321. Elle permet les formats de données définis dans le RFC 6532 [RFC6532], mais elle ne modifie pas le RFC 5322. Elle exige que l'extension 8BITMIME [RFC6152] soit annoncée par le serveur SMTP compatible SMTPUTF8 et utilisée avec "BODY=8BITMIME" par le client SMTP compatible SMTPUTF8, mais elle ne modifie en aucune façon la spécification 8BITMIME.
Cette spécification remplace une approche antérieure, expérimentale, du même problème [RFC5336]. La section 6 du RFC 6530 [RFC6530] décrit les changements d'approche entre le RFC 5336 [RFC5336] et cette spécification. Quiconque tente de convertir une implémentation de la spécification expérimentale à la spécification de ce document devra examiner ces changements avec soin.