1. 引言
本文档定义了一个简单邮件传输协议 (Simple Mail Transfer Protocol, SMTP) [RFC5321] 扩展, 使服务器能够通告其接受并处理国际化电子邮件地址 (见第 1.1 节) 和国际化电子邮件头部 [RFC6532] 的能力.
关于国际化电子邮件地址和电子邮件头部的扩展模型的一个更详尽的概述出现在 RFC 6530 [RFC6530] 中, 在本规范中将其称为 "框架文档" (the framework document). 要理解并实现本规范, 必须透彻理解该文档以及 Internet 电子邮件基础规范 [RFC5321] [RFC5322] 中的信息.
1.1. 术语
本文档中的关键词 "MUST"、"MUST NOT"、"REQUIRED"、"SHALL"、"SHALL NOT"、"SHOULD"、"SHOULD NOT"、"RECOMMENDED"、"MAY" 和 "OPTIONAL" 应按照 RFC 2119 [RFC2119] 中的描述进行解释.
术语 "UTF-8 字符串" 或 "UTF-8 字符" 用于指代 Unicode 字符, 这些字符可能是也可能不是 ASCII 子集的成员, 它们以 UTF-8 [RFC3629] (一种标准的 Unicode 编码形式) 表示. 本规范中使用的所有其他专门术语都在框架文档或 Internet 电子邮件基础规范中定义. 特别地, 本文档中使用的术语 "ASCII 地址" (ASCII address)、"国际化电子邮件地址" (internationalized email address)、"非 ASCII 地址" (non-ASCII address)、"SMTPUTF8"、"国际化消息" (internationalized message) 和 "消息" (message) 均按照框架文档 [RFC6530] 中的定义使用.
本文档中提及的字符串, 包括 ASCII 字符串, 都必须 (MUST) 以 UTF-8 表示.
本规范使用扩充巴科斯范式 (Augmented BNF, ABNF) 规则 [RFC5234]. 本文档中的一些基本规则在第 3.3 节中被标识为已在 RFC 5234 [RFC5234]、RFC 5321 [RFC5321]、RFC 5890 [RFC5890] 或 RFC 6532 [RFC6532] 中定义 (使用相同的名称).
1.2. 对其他规范的变更
本规范扩展了 RFC 5321 中定义的一些语法规则, 并允许在信封 (envelope) 和跟踪字段 (trace field) 中使用国际化电子邮件地址, 但它不修改 RFC 5321. 它允许使用 RFC 6532 [RFC6532] 中定义的数据格式, 但不修改 RFC 5322. 它确实要求支持 SMTPUTF8 的 SMTP 服务器 (SMTPUTF8-aware SMTP server) 通告 8BITMIME 扩展 [RFC6152], 并且支持 SMTPUTF8 的 SMTP 客户端 (SMTPUTF8-aware SMTP client) 使用 "BODY=8BITMIME", 但它不以任何方式修改 8BITMIME 规范.
本规范取代了针对同一问题的一种较早的、实验性的方法 [RFC5336]. RFC 6530 [RFC6530] 的第 6 节描述了 RFC 5336 [RFC5336] 与本规范之间方法上的变化. 任何试图将实现从该实验性规范转换到本文档规范的人都需要仔细审阅这些变化.