1. はじめに
このドキュメントは、サーバーが国際化された電子メールアドレス(セクション1.1を参照)および国際化された電子メールヘッダー[RFC6532]を受け入れて処理する機能をアドバタイズできるように、Simple Mail Transfer Protocol [RFC5321]拡張を定義します。
国際化された電子メールアドレスと電子メールヘッダーの拡張モデルの拡張概要は、RFC 6530 [RFC6530]に記載されており、この仕様では「フレームワークドキュメント」と呼ばれています。
この仕様を理解し実装するには、そのドキュメントおよび基本的なインターネット電子メール仕様[RFC5321] [RFC5322]の情報を十分に理解する必要があります。
1.1. 用語
このドキュメントのキーワード "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", および "OPTIONAL" は、RFC 2119 [RFC2119]で説明されているように解釈されます。
用語「UTF-8文字列」または「UTF-8文字」は、標準のUnicodeエンコーディング形式であるUTF-8 [RFC3629]において、ASCIIサブセットのメンバーであるかどうかにかかわらず、Unicode文字を指すために使用されます。
この仕様で使用される他のすべての専門用語は、フレームワークドキュメントまたは基本的なインターネット電子メール仕様で定義されています。
特に、「ASCIIアドレス」、「国際化された電子メールアドレス」、「非ASCIIアドレス」、「SMTPUTF8」、「国際化されたメッセージ」、および「メッセージ」という用語は、フレームワークドキュメント[RFC6530]の定義に従ってこのドキュメントで使用されます。
このドキュメントで参照される文字列は、ASCII文字列を含め、UTF-8で表現されなければなりません(MUST)。
この仕様では、Augmented BNF(ABNF)ルール[RFC5234]を使用します。
このドキュメントのいくつかの基本的なルールは、セクション3.3で、RFC 5234 [RFC5234]、RFC 5321 [RFC5321]、RFC 5890 [RFC5890]、またはRFC 6532 [RFC6532]で(同じ名前で)定義されているものとして識別されます。
1.2. 他の仕様に対する変更
この仕様は、RFC 5321で定義されているいくつかの構文規則を拡張し、エンベロープおよびトレースフィールドでの国際化された電子メールアドレスを許可しますが、RFC 5321は変更しません。
RFC 6532 [RFC6532]で定義されているデータ形式を許可しますが、RFC 5322は変更しません。
SMTPUTF8対応SMTPサーバーによって8BITMIME拡張[RFC6152]がアナウンスされ、SMTPUTF8対応SMTPクライアントによって "BODY=8BITMIME" とともに使用されることを要求しますが、8BITMIME仕様はいかなる方法でも変更しません。
この仕様は、同じ問題に対する以前の実験的なアプローチ[RFC5336]を置き換えます。
RFC 6530 [RFC6530]のセクション6では、RFC 5336 [RFC5336]とこの仕様の間のアプローチの変更について説明しています。
実験的な仕様からこのドキュメントの仕様に実装を変換しようとする人は、それらの変更を注意深く確認する必要があります。