1. Einführung
Dieses Dokument definiert eine Erweiterung des Simple Mail Transfer Protocol [RFC5321], damit Server die Fähigkeit ankündigen können, internationalisierte E-Mail-Adressen (siehe Abschnitt 1.1) und internationalisierte E-Mail-Header [RFC6532] zu akzeptieren und zu verarbeiten.
Ein erweiterter Überblick über das Erweiterungsmodell für internationalisierte E-Mail-Adressen und den E-Mail-Header findet sich in RFC 6530 [RFC6530], das in dieser Spezifikation als "das Rahmenwerk-Dokument" bezeichnet wird. Ein gründliches Verständnis der Informationen in diesem Dokument und in den grundlegenden Internet-E-Mail-Spezifikationen [RFC5321] [RFC5322] ist notwendig, um diese Spezifikation zu verstehen und zu implementieren.
1.1. Terminologie
Die Schlüsselwörter "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" und "OPTIONAL" in diesem Dokument sind so zu interpretieren, wie in RFC 2119 [RFC2119] beschrieben.
Die Begriffe "UTF-8-Zeichenkette" oder "UTF-8-Zeichen" werden verwendet, um auf Unicode-Zeichen zu verweisen, die Mitglieder der ASCII-Teilmenge sein können oder auch nicht, in UTF-8 [RFC3629], einer Standard-Unicode-Kodierungsform. Alle anderen spezialisierten Begriffe, die in dieser Spezifikation verwendet werden, sind im Rahmenwerk-Dokument oder in den grundlegenden Internet-E-Mail-Spezifikationen definiert. Insbesondere werden die Begriffe "ASCII-Adresse", "internationalisierte E-Mail-Adresse", "Nicht-ASCII-Adresse", "SMTPUTF8", "internationalisierte Nachricht" und "Nachricht" in diesem Dokument gemäß den Definitionen im Rahmenwerk-Dokument [RFC6530] verwendet.
Zeichenketten, auf die in diesem Dokument verwiesen wird, einschließlich ASCII-Zeichenketten, MÜSSEN in UTF-8 ausgedrückt werden.
Diese Spezifikation verwendet Regeln der erweiterten Backus-Naur-Form (ABNF) [RFC5234]. Einige grundlegende Regeln in diesem Dokument werden in Abschnitt 3.3 als (unter denselben Namen) definiert in RFC 5234 [RFC5234], RFC 5321 [RFC5321], RFC 5890 [RFC5890] oder RFC 6532 [RFC6532] identifiziert.
1.2. Änderungen an anderen Spezifikationen
Diese Spezifikation erweitert einige in RFC 5321 definierte Syntaxregeln und erlaubt internationalisierte E-Mail-Adressen im Umschlag und in Trace-Feldern, modifiziert jedoch nicht RFC 5321. Sie erlaubt in RFC 6532 [RFC6532] definierte Datenformate, modifiziert jedoch nicht RFC 5322. Sie erfordert, dass die 8BITMIME-Erweiterung [RFC6152] vom SMTPUTF8-fähigen SMTP-Server angekündigt und vom SMTPUTF8-fähigen SMTP-Client mit "BODY=8BITMIME" verwendet wird, modifiziert jedoch die 8BITMIME-Spezifikation in keiner Weise.
Diese Spezifikation ersetzt einen früheren, experimentellen Ansatz für dasselbe Problem [RFC5336]. Abschnitt 6 von RFC 6530 [RFC6530] beschreibt die Änderungen im Ansatz zwischen RFC 5336 [RFC5336] und dieser Spezifikation. Jeder, der versucht, eine Implementierung von der experimentellen Spezifikation auf die Spezifikation in diesem Dokument umzustellen, muss diese Änderungen sorgfältig prüfen.