1. Introduction
Un moyen d'indiquer les relations entre les ressources sur le Web, ainsi que le type de ces relations, est disponible depuis un certain temps en HTML [W3C.REC-html401-19991224], et plus récemment en Atom [RFC4287]. Ces mécanismes, bien que conceptuellement similaires, sont spécifiés séparément. Cependant, les liens entre ressources n'ont pas besoin d'être spécifiques à un format ; il peut être utile de disposer de liens typés (typed links) indépendants de leur sérialisation, en particulier lorsqu'une ressource possède des représentations dans plusieurs formats.
À cette fin, ce document définit un cadre pour les liens typés qui n'est pas spécifique à une sérialisation ou à une application particulière. Il le fait en redéfinissant le registre des types de relation de lien établi par Atom afin de lui donner un domaine plus large, et en y ajoutant les relations définies par HTML.
En outre, un champ d'en-tête HTTP permettant de transporter des liens typés a été défini à la section 19.6.2.4 de [RFC2068], mais a été supprimé de [RFC2616], faute d'expérience d'implémentation. Depuis lors, il a été implémenté dans certains agents utilisateurs (par exemple, pour les feuilles de style), et plusieurs cas d'utilisation supplémentaires ont été mis au jour.
Parce qu'il a été supprimé, le statut de l'en-tête Link est incertain, ce qui a conduit certains à envisager de créer de nouveaux en-têtes HTTP spécifiques à une application plutôt que de le réutiliser. Ce document répond à cela en re-spécifiant l'en-tête Link comme l'une de ces sérialisations, avec une syntaxe mise à jour mais rétrocompatible.