跳到主要内容

1. 引言

用于指示 Web 上资源之间关系并指示这些关系类型的手段, 已经在 HTML [W3C.REC-html401-19991224] 中存在了一段时间, 并且最近也在 Atom [RFC4287] 中出现. 这些机制虽然在概念上相似, 但却是分别规定的. 然而, 资源之间的链接不必特定于某种格式; 拥有独立于其序列化形式的类型化链接 (typed link) 可能很有用, 尤其是当某个资源具有多种格式的表示形式时.

为此, 本文档定义了一个不特定于某种序列化形式或应用的类型化链接框架. 其做法是重新定义由 Atom 建立的链接关系注册表, 使其具有更广泛的作用域, 并向其中加入由 HTML 定义的关系.

此外, 一种用于传递类型化链接的 HTTP 头字段曾在 [RFC2068] 第 19.6.2.4 节中定义, 但由于缺乏实现经验, 它已被从 [RFC2616] 中移除. 自那以后, 它已在一些用户代理 (User Agent) 中实现 (例如用于样式表), 并且还出现了若干额外的用例.

由于它被移除, Link 头的状态并不明确, 这使一些人考虑改为铸造新的、特定于应用的 HTTP 头, 而不是复用它. 本文档通过把 Link 头重新规定为此类序列化形式之一来解决这一问题, 其语法经过更新但仍向后兼容.