7. 安全考虑事项
Link 头字段的内容并不安全、不具私密性, 也不保证完整性, 使用它时应保持应有的谨慎. 在 HTTP 中使用传输层安全 (Transport Layer Security, TLS) ([RFC2818] 和 [RFC2817]) 目前是提供此类保护的唯一端到端方式. 利用类型化链接的应用应考虑自动跟随、信任或以其他方式使用从 HTTP 头中收集到的链接所引入的攻击途径. 特别是, 使用 "anchor" 参数把链接的上下文与另一个资源关联起来的 Link 头, 应予以应有的谨慎处理.
Link 实体头字段大量使用 IRI 和 URI. 有关 IRI 的安全考虑事项见 [RFC3987]. 有关 URI 的安全考虑事项见 [RFC3986]. 有关 HTTP 头的安全考虑事项见 [RFC2616].