Passa al contenuto principale

1. Introduzione

Un mezzo per indicare le relazioni tra le risorse sul Web, nonché per indicare il tipo di tali relazioni, è disponibile da tempo in HTML [W3C.REC-html401-19991224] e, più recentemente, in Atom [RFC4287]. Questi meccanismi, sebbene concettualmente simili, sono specificati separatamente. Tuttavia, i link tra risorse non devono necessariamente essere specifici di un formato; può essere utile disporre di link tipizzati (typed link) indipendenti dalla loro serializzazione, soprattutto quando una risorsa ha rappresentazioni in più formati.

A questo scopo, il presente documento definisce un quadro per i link tipizzati che non è specifico di una particolare serializzazione o applicazione. Esso lo fa ridefinendo il registro dei tipi di relazione dei link stabilito da Atom in modo che abbia un dominio più ampio, e aggiungendovi le relazioni definite da HTML.

Inoltre, un campo di intestazione HTTP per veicolare link tipizzati è stato definito nella Sezione 19.6.2.4 di [RFC2068], ma rimosso da [RFC2616], a causa della mancanza di esperienza di implementazione. Da allora, esso è stato implementato in alcuni User Agent (ad esempio, per i fogli di stile) e sono emersi diversi casi d'uso aggiuntivi.

Poiché è stato rimosso, lo stato dell'intestazione Link è poco chiaro, il che ha portato alcuni a considerare la creazione di nuove intestazioni HTTP specifiche per l'applicazione invece di riutilizzarla. Il presente documento affronta questo problema rispecificando l'intestazione Link come una di tali serializzazioni, con una sintassi aggiornata ma retrocompatibile.