Passa al contenuto principale

7. Considerazioni sulla sicurezza

Il contenuto del campo di intestazione Link non è sicuro, privato né garantito nell'integrità, e si dovrebbe usare la dovuta cautela quando lo si utilizza. L'uso di Transport Layer Security (TLS) con HTTP ([RFC2818] e [RFC2817]) è attualmente l'unico modo end-to-end per fornire tale protezione. Le applicazioni che traggono vantaggio dai link tipizzati dovrebbero considerare i vettori di attacco aperti dal seguire, dal fidarsi o dall'usare in altro modo automaticamente i link raccolti dalle intestazioni HTTP. In particolare, le intestazioni Link che usano il parametro "anchor" per associare il contesto di un link a un'altra risorsa dovrebbero essere trattate con la dovuta cautela.

Il campo di intestazione di entità Link fa ampio uso di IRI e URI. Vedere [RFC3987] per le considerazioni sulla sicurezza relative agli IRI. Vedere [RFC3986] per le considerazioni sulla sicurezza relative agli URI. Vedere [RFC2616] per le considerazioni sulla sicurezza relative alle intestazioni HTTP.