Aller au contenu principal

6. Considérations IANA

Cette spécification met à jour l'entrée du registre Message Header pour "Link" dans HTTP [RFC3864] afin qu'elle renvoie à ce document.

Header field: Link
Applicable protocol: http
Status: standard
Author/change controller:
IETF ([email protected])
Internet Engineering Task Force
Specification document(s):
[RFC5988]

6.2. Registre des types de relation de lien​

Cette spécification établit le registre des types de relation de lien, et met à jour Atom [RFC4287] afin qu'il y renvoie à la place du "Registry of Link Relations".

Les données du registre sous-jacent (par exemple, le fichier XML) doivent inclure le texte de la licence BSD simplifiée tel que décrit à la section 4.e des dispositions légales de l'IETF Trust (http://trustee.ietf.org/license-info).

6.2.1. Enregistrement de nouveaux types de relation de lien​

Les types de relation sont enregistrés sur avis d'un expert désigné (Designated Expert) (nommé par l'IESG ou son délégué), selon la politique "Specification Required" (en utilisant la terminologie de [RFC5226]).

Les exigences relatives aux types de relation enregistrés sont décrites à la section 4.1.

Les demandes d'enregistrement consistent en le modèle d'enregistrement complété ci-dessous, généralement publié dans un RFC ou une norme ouverte (au sens décrit par [RFC2026], section 7). Cependant, afin de permettre l'attribution de valeurs avant publication, l'expert désigné peut approuver un enregistrement dès qu'il est convaincu qu'une spécification sera publiée.

Notez que les types de relation peuvent être enregistrés par des tiers, si l'expert désigné détermine qu'un type de relation non enregistré est largement déployé et n'est probablement pas enregistré en temps voulu.

Le modèle d'enregistrement est :

Relation Name:

Description:

Reference:

Notes: [optional]

Application Data: [optional]

Les demandes d'enregistrement devraient être envoyées à la liste de diffusion [email protected], clairement marquées dans la ligne d'objet (par exemple, "NEW RELATION - example" pour enregistrer un type de relation "example").

Dans un délai maximal de 14 jours à compter de la demande, le ou les experts désignés approuveront ou refuseront la demande d'enregistrement, en communiquant cette décision à la liste de relecture et à l'IANA. Les refus devraient inclure une explication et, le cas échéant, des suggestions sur la manière de rendre la demande acceptable.

Les décisions (ou l'absence de décision) prises par l'expert désigné peuvent faire l'objet d'un premier recours auprès des directeurs de domaine Application (joignables à l'aide de l'adresse électronique [email protected] ou directement en recherchant leurs adresses électroniques sur le site http://www.iesg.org/) et, si l'appelant n'est pas satisfait de la réponse, auprès de l'IESG complet (à l'aide de la liste de diffusion [email protected]). L'IANA ne devrait accepter les mises à jour du registre que de la part du ou des experts désignés, et devrait diriger toutes les demandes d'enregistrement vers la liste de diffusion de relecture.

6.2.2. Contenu initial du registre​

Le contenu initial du registre des types de relation de lien est :

Relation Name: alternate
Description: Designates a substitute for the link's context.
Reference: [W3C.REC-html401-19991224]

Relation Name: appendix
Description: Refers to an appendix.
Reference: [W3C.REC-html401-19991224]

Relation Name: bookmark
Description: Refers to a bookmark or entry point.
Reference: [W3C.REC-html401-19991224]

Relation Name: chapter
Description: Refers to a chapter in a collection of resources.
Reference: [W3C.REC-html401-19991224]

Relation Name: contents
Description: Refers to a table of contents.
Reference: [W3C.REC-html401-19991224]

Relation Name: copyright
Description: Refers to a copyright statement that applies to the
   link's context.
Reference: [W3C.REC-html401-19991224]

Relation Name: current
Description: Refers to a resource containing the most recent
   item(s) in a collection of resources.
Reference: [RFC5005]

Relation Name: describedby
Description: Refers to a resource providing information about the
   link's context.
Documentation: <http://www.w3.org/TR/powder-dr/#assoc-linking>

Relation Name: edit
Description: Refers to a resource that can be used to edit the
   link's context.
Reference: [RFC5023]

Relation Name: edit-media
Description: Refers to a resource that can be used to edit media
   associated with the link's context.
Reference: [RFC5023]

Relation Name: enclosure
Description: Identifies a related resource that is potentially
   large and might require special handling.
Reference: [RFC4287]

Relation Name: first
Description: An IRI that refers to the furthest preceding resource
   in a series of resources.
Reference: [RFC5988]
Notes: this relation type registration did not indicate a
   reference.  Originally requested by Mark Nottingham in December
   2004.

Relation Name: glossary
Description: Refers to a glossary of terms.
Reference: [W3C.REC-html401-19991224]

Relation Name: help
Description: Refers to a resource offering help (more information,
   links to other sources information, etc.)
Reference: [W3C.REC-html401-19991224]

Relation Name: hub
Description: Refers to a hub that enables registration for
   notification of updates to the context.
Reference: <http://pubsubhubbub.googlecode.com/> <http://
   pubsubhubbub.googlecode.com/svn/trunk/pubsubhubbub-core-0.3.html>
Notes: this relation type was requested by Brett Slatkin.

Relation Name: index
Description: Refers to an index.
Reference: [W3C.REC-html401-19991224]

Relation Name: last
Description: An IRI that refers to the furthest following resource
   in a series of resources.
Reference: [RFC5988]
Notes: this relation type registration did not indicate a
   reference.  Originally requested by Mark Nottingham in December
   2004.

Relation Name: latest-version
Description: Points to a resource containing the latest (e.g.,
   current) version of the context.
Reference: [RFC5829]

Relation Name: license
Description: Refers to a license associated with the link's
   context.
Reference: [RFC4946]

Relation Name: next
Description: Refers to the next resource in a ordered series of
   resources.
Reference: [W3C.REC-html401-19991224]

Relation Name: next-archive
Description: Refers to the immediately following archive resource.
Reference: [RFC5005]

Relation Name: payment
Description: indicates a resource where payment is accepted.
Reference: [RFC5988]
Notes: this relation type registration did not indicate a
   reference.  Requested by Joshua Kinberg and Robert Sayre.  It is
   meant as a general way to facilitate acts of payment, and thus
   this specification makes no assumptions on the type of payment or
   transaction protocol.  Examples may include a Web page where
   donations are accepted or where goods and services are available
   for purchase. rel="payment" is not intended to initiate an
   automated transaction.  In Atom documents, a link element with a
   rel="payment" attribute may exist at the feed/channel level and/or
   the entry/item level.  For example, a rel="payment" link at the
   feed/channel level may point to a "tip jar" URI, whereas an entry/
   item containing a book review may include a rel="payment" link
   that points to the location where the book may be purchased
   through an online retailer.

Relation Name: prev
Description: Refers to the previous resource in an ordered series
   of resources.  Synonym for "previous".
Reference: [W3C.REC-html401-19991224]

Relation Name: predecessor-version
Description: Points to a resource containing the predecessor
   version in the version history.
Reference: [RFC5829]

Relation Name: previous
Description: Refers to the previous resource in an ordered series
   of resources.  Synonym for "prev".
Reference: [W3C.REC-html401-19991224]

Relation Name: prev-archive
Description: Refers to the immediately preceding archive resource.
Reference: [RFC5005]

Relation Name: related
Description: Identifies a related resource.
Reference: [RFC4287]

Relation Name: replies
Description: Identifies a resource that is a reply to the context
   of the link.
Reference: [RFC4685]

Relation Name: section
Description: Refers to a section in a collection of resources.
Reference: [W3C.REC-html401-19991224]

Relation Name: self
Description: Conveys an identifier for the link's context.
Reference: [RFC4287]

Relation Name: service
Description: Indicates a URI that can be used to retrieve a
   service document.
Reference: [RFC5023]
Notes: When used in an Atom document, this relation type specifies
   Atom Publishing Protocol service documents by default.  Requested
   by James Snell.

Relation Name: start
Description: Refers to the first resource in a collection of
   resources.
Reference: [W3C.REC-html401-19991224]

Relation Name: stylesheet
Description: Refers to an external style sheet.
Reference: [W3C.REC-html401-19991224]

Relation Name: subsection
Description: Refers to a resource serving as a subsection in a
   collection of resources.
Reference: [W3C.REC-html401-19991224]

Relation Name: successor-version
Description: Points to a resource containing the successor version
   in the version history.
Reference: [RFC5829]

Relation Name: up
Description: Refers to a parent document in a hierarchy of
   documents.
Reference: [RFC5988]
Notes: this relation type registration did not indicate a
   reference.  Requested by Noah Slater.

Relation Name: version-history
Description: points to a resource containing the version history
   for the context.
Reference: [RFC5829]

Relation Name: via
Description: Identifies a resource that is the source of the
   information in the link's context.
Reference: [RFC4287]

Relation Name: working-copy
Description: Points to a working copy for this resource.
Reference: [RFC5829]

Relation Name: working-copy-of
Description: Points to the versioned resource from which this
   working copy was obtained.
Reference: [RFC5829]

6.3. Registre des données d'application des relations de lien​

Cette spécification établit également le registre Link Relation Application Field, afin de permettre aux entrées du registre des types de relation de lien d'être étendues avec des données spécifiques à l'application (ci-après, "app data") propres à toutes les instances d'un type de relation de lien donné.

Les données d'application sont enregistrées sur avis d'un expert désigné (nommé par l'IESG ou son délégué), selon la politique "Specification Required" (en utilisant la terminologie de [RFC5226]). Les demandes d'enregistrement consistent en le modèle d'enregistrement complété ci-dessous :

Application Name:

Description:

Default Value:

Notes: [optional]

La Description devrait (SHOULD) identifier l'espace de valeurs des app data. La valeur par défaut doit (MUST) être appropriée aux entrées auxquelles les app data ne s'appliquent pas.

Les entrées antérieures à l'ajout des app data seront automatiquement considérées comme ayant la valeur par défaut pour ces app data ; s'il existe des exceptions, la modification de ces entrées devrait être coordonnée par le ou les experts désignés, en consultation avec l'auteur des app data proposées ainsi qu'avec le déclarant de l'entrée existante (si possible).

Les demandes d'enregistrement devraient être envoyées à la liste de diffusion [email protected], clairement marquées dans la ligne d'objet (par exemple, "NEW APP DATA - example" pour enregistrer les app data "example").

Dans un délai maximal de 14 jours à compter de la demande, l'expert désigné approuvera ou refusera la demande d'enregistrement, en communiquant cette décision à la liste de relecture. Les refus devraient inclure une explication et, le cas échéant, des suggestions sur la manière de rendre la demande acceptable. Les demandes d'enregistrement qui restent indéterminées pendant une période supérieure à 21 jours peuvent être portées à l'attention de l'IESG (à l'aide de la liste de diffusion [email protected]) pour résolution.

Lorsqu'une demande d'enregistrement aboutit, l'expert désigné la transmettra à l'IANA pour publication. L'IANA ne devrait accepter les mises à jour du registre que de la part du ou des experts désignés, et devrait diriger toutes les demandes d'enregistrement vers la liste de diffusion de relecture.