2. Introduction
Comme indiqué dans le RFC 1052, IAB Recommendations for the Development of Internet Network Management Standards [1], une stratégie à deux volets pour la gestion de réseau des réseaux interconnexés fondés sur TCP/IP a été entreprise. À court terme, le Simple Network Management Protocol (SNMP) devait être utilisé pour gérer les nœuds de la communauté Internet. À long terme, l'utilisation du cadre de gestion de réseau OSI devait être examinée. Deux documents ont été produits pour définir les informations de gestion : le RFC 1065, qui définissait la Structure des informations de gestion (SMI) [2], et le RFC 1066, qui définissait la Base d'informations de gestion (MIB) [3]. Ces deux documents ont été conçus de manière à être compatibles à la fois avec le SNMP et avec le cadre de gestion de réseau OSI.
Cette stratégie a été assez couronnée de succès à court terme : la technologie de gestion de réseau fondée sur Internet a été déployée, tant par les communautés de la recherche que par les communautés commerciales, en quelques mois. Il en est résulté que des parties de la communauté Internet sont devenues gérables en réseau en temps utile.
Comme indiqué dans le RFC 1109, Report of the Second Ad Hoc Network Management Review Group [4], les exigences des cadres de gestion de réseau SNMP et OSI étaient plus différentes que prévu. En conséquence, l'exigence de compatibilité entre le SMI/MIB et les deux cadres a été suspendue. Cette mesure a permis au cadre de gestion de réseau opérationnel, le SNMP, de répondre aux nouveaux besoins opérationnels de la communauté Internet en produisant des documents définissant de nouveaux éléments de MIB.
L'IAB a désigné le SNMP, le SMI et la MIB Internet initiale comme des « Standard Protocols » complets ayant le statut « Recommended ». Par cette action, l'IAB recommande que toutes les implémentations IP et TCP soient gérables en réseau et que les implémentations qui sont gérables en réseau soient censées adopter et mettre en œuvre le SMI, la MIB et le SNMP.
En tant que tel, le cadre actuel de gestion de réseau pour les réseaux interconnexés fondés sur TCP/IP se compose de : Structure and Identification of Management Information for TCP/IP-based Internets, qui décrit comment les objets gérés contenus dans la MIB sont définis conformément au RFC 1155 [5] ; Management Information Base for Network Management of TCP/IP-based Internets, qui décrit les objets gérés contenus dans la MIB conformément au RFC 1156 [6] ; et le Simple Network Management Protocol, qui définit le protocole utilisé pour gérer ces objets, conformément au présent mémo.
Comme indiqué dans le RFC 1052, IAB Recommendations for the Development of Internet Network Management Standards [1], l'Internet Activities Board a demandé à l'Internet Engineering Task Force (IETF) de créer deux nouveaux groupes de travail dans le domaine de la gestion de réseau. Un groupe a été chargé de la spécification et de la définition plus poussées des éléments à inclure dans la Base d'informations de gestion (MIB). L'autre a été chargé de définir les modifications du Simple Network Management Protocol (SNMP) afin de répondre aux besoins à court terme des communautés des fournisseurs de réseau et de l'exploitation, et de s'aligner sur les travaux du groupe de travail sur la MIB.
Le groupe de travail sur la MIB a produit deux mémos, l'un qui définit une Structure des informations de gestion (SMI) [2] destinée à être utilisée par les objets gérés contenus dans la MIB. Un second mémo [3] définit la liste des objets gérés.
Les travaux du groupe de travail SNMP Extensions constituent le présent mémo, qui intègre les modifications de la définition initiale du SNMP [7] nécessaires pour s'aligner sur les travaux du groupe de travail sur la MIB. Les modifications devaient être minimales afin de rester cohérentes avec la directive de l'IAB selon laquelle les groupes de travail doivent être « extrêmement attentifs à la nécessité de garder le SNMP simple ». Bien qu'un soin et un débat considérables aient accompagné les modifications du SNMP reflétées dans ce mémo, le protocole résultant n'est pas rétrocompatible avec son prédécesseur, le Simple Gateway Monitoring Protocol (SGMP) [8]. Bien que la syntaxe du protocole ait été modifiée, la philosophie d'origine, les décisions de conception et l'architecture restent intactes. Afin d'éviter toute confusion, de nouveaux ports UDP ont été alloués pour être utilisés par le protocole décrit dans ce mémo.