Zum Hauptinhalt springen

2. Einleitung

Wie in RFC 1052, IAB Recommendations for the Development of Internet Network Management Standards [1], berichtet wird, wurde eine zweigleisige Strategie für das Netzwerkmanagement TCP/IP-basierter Internets eingeschlagen. Kurzfristig sollte das Simple Network Management Protocol (SNMP) verwendet werden, um Knoten in der Internet-Gemeinschaft zu verwalten. Langfristig sollte die Verwendung des OSI-Netzwerkmanagement-Rahmens untersucht werden. Zur Definition der Management-Informationen wurden zwei Dokumente erstellt: RFC 1065, der die Structure of Management Information (SMI) [2] definierte, und RFC 1066, der die Management Information Base (MIB) [3] definierte. Beide Dokumente wurden so gestaltet, dass sie sowohl mit dem SNMP als auch mit dem OSI-Netzwerkmanagement-Rahmen kompatibel sind.

Diese Strategie war kurzfristig recht erfolgreich: Innerhalb weniger Monate wurde von der Forschungs- und der kommerziellen Gemeinschaft internetbasierte Netzwerkmanagement-Technologie eingesetzt. Infolgedessen wurden Teile der Internet-Gemeinschaft rechtzeitig über das Netzwerk verwaltbar.

Wie in RFC 1109, Report of the Second Ad Hoc Network Management Review Group [4], berichtet wird, unterschieden sich die Anforderungen des SNMP und der OSI-Netzwerkmanagement-Rahmen stärker als erwartet. Daher wurde die Anforderung der Kompatibilität zwischen der SMI/MIB und beiden Rahmen ausgesetzt. Dieser Schritt ermöglichte es dem operativen Netzwerkmanagement-Rahmen, dem SNMP, auf neue operative Bedürfnisse in der Internet-Gemeinschaft zu reagieren, indem Dokumente erstellt wurden, die neue MIB-Einträge definieren.

Das IAB hat das SNMP, die SMI und die anfängliche Internet-MIB als vollwertige „Standard Protocols" mit dem Status „Recommended" eingestuft. Mit diesem Schritt empfiehlt das IAB, dass alle IP- und TCP-Implementierungen über das Netzwerk verwaltbar sind, und dass die Implementierungen, die über das Netzwerk verwaltbar sind, die SMI, MIB und SNMP übernehmen und implementieren sollten.

Somit besteht der derzeitige Netzwerkmanagement-Rahmen für TCP/IP-basierte Internets aus: Structure and Identification of Management Information for TCP/IP-based Internets, die beschreibt, wie die in der MIB enthaltenen verwalteten Objekte gemäß RFC 1155 [5] definiert sind; Management Information Base for Network Management of TCP/IP-based Internets, die die in der MIB enthaltenen verwalteten Objekte gemäß RFC 1156 [6] beschreibt; und dem Simple Network Management Protocol, das das zur Verwaltung dieser Objekte verwendete Protokoll gemäß diesem Memo definiert.

Wie in RFC 1052, IAB Recommendations for the Development of Internet Network Management Standards [1], berichtet wird, hat das Internet Activities Board die Internet Engineering Task Force (IETF) angewiesen, zwei neue Arbeitsgruppen im Bereich Netzwerkmanagement zu bilden. Eine Gruppe wurde mit der weiteren Spezifikation und Definition der Elemente beauftragt, die in die Management Information Base (MIB) aufzunehmen sind. Die andere wurde damit beauftragt, die Änderungen am Simple Network Management Protocol (SNMP) zu definieren, um den kurzfristigen Bedürfnissen der Netzwerkanbieter- und Betriebsgemeinschaften gerecht zu werden und mit den Ergebnissen der MIB-Arbeitsgruppe übereinzustimmen.

Die MIB-Arbeitsgruppe erstellte zwei Memos; eines davon definiert eine Structure for Management Information (SMI) [2] zur Verwendung durch die in der MIB enthaltenen verwalteten Objekte. Ein zweites Memo [3] definiert die Liste der verwalteten Objekte.

Das Ergebnis der Arbeitsgruppe SNMP Extensions ist dieses Memo, das Änderungen an der ursprünglichen SNMP-Definition [7] enthält, die erforderlich sind, um Übereinstimmung mit den Ergebnissen der MIB-Arbeitsgruppe zu erzielen. Die Änderungen sollten minimal sein, um mit der Anweisung des IAB übereinzustimmen, dass die Arbeitsgruppen „äußerst sensibel für die Notwendigkeit sein müssen, das SNMP einfach zu halten". Obwohl beträchtliche Sorgfalt und Diskussion in die in diesem Memo widergespiegelten Änderungen am SNMP eingeflossen sind, ist das resultierende Protokoll nicht abwärtskompatibel mit seinem Vorgänger, dem Simple Gateway Monitoring Protocol (SGMP) [8]. Obwohl die Syntax des Protokolls geändert wurde, bleiben die ursprüngliche Philosophie, die Entwurfsentscheidungen und die Architektur unverändert. Um Verwechslungen zu vermeiden, wurden neue UDP-Ports für die Verwendung durch das in diesem Memo beschriebene Protokoll zugewiesen.