跳到主要内容

2. 引言

如 RFC 1052《IAB Recommendations for the Development of Internet Network Management Standards》[1] 所述,当时对基于 TCP/IP 的互联网络的网络管理采取了一种双管齐下的策略。短期内,将使用简单网络管理协议(SNMP)来管理 Internet 社区中的节点。长期内,将考察 OSI 网络管理框架的使用。为定义管理信息产生了两个文档:RFC 1065,它定义了管理信息结构(SMI)[2];以及 RFC 1066,它定义了管理信息库(MIB)[3]。这两个文档在设计上都与 SNMP 和 OSI 网络管理框架兼容。

这一策略在短期内相当成功:基于 Internet 的网络管理技术在几个月内就由研究界和商业界部署实施。其结果是,Internet 社区的部分区域及时地实现了可网络管理。

如 RFC 1109《Report of the Second Ad Hoc Network Management Review Group》[4] 所述,SNMP 与 OSI 网络管理框架的需求差异比预期的更大。因此,SMI/MIB 与这两个框架之间兼容性的要求被搁置。这一举措使得可实际运行的网络管理框架——即 SNMP——能够通过制定定义新 MIB 项的文档来响应 Internet 社区新的运行需求。

IAB 已将 SNMP、SMI 和最初的 Internet MIB 指定为具有"推荐"地位的完整"标准协议"。通过这一举措,IAB 建议所有 IP 和 TCP 实现都应当是可网络管理的,并且期望那些可网络管理的实现采用并实现 SMI、MIB 和 SNMP。

因此,当前基于 TCP/IP 的互联网络的网络管理框架由以下部分组成:Structure and Identification of Management Information for TCP/IP-based Internets,它按 RFC 1155 [5] 的规定描述 MIB 中包含的被管对象是如何定义的;Management Information Base for Network Management of TCP/IP-based Internets,它按 RFC 1156 [6] 的规定描述 MIB 中包含的被管对象;以及 Simple Network Management Protocol,它按本备忘录的规定定义用于管理这些对象的协议。

如 RFC 1052《IAB Recommendations for the Development of Internet Network Management Standards》[1] 所述,Internet Activities Board 已指示 Internet Engineering Task Force (IETF) 在网络管理领域创建两个新的工作组。一个组负责进一步规范和定义要纳入管理信息库(MIB)的元素。另一个组负责定义对简单网络管理协议(SNMP)的修改,以满足网络厂商和运行社区的短期需求,并与 MIB 工作组的产出保持一致。

MIB 工作组产生了两个备忘录,其中一个定义了管理信息结构(SMI)[2],供 MIB 中包含的被管对象使用。第二个备忘录 [3] 定义了被管对象的列表。

SNMP 扩展工作组的产出就是本备忘录,它纳入了为与 MIB 工作组的产出保持一致而对最初的 SNMP 定义 [7] 所做的修改。这些修改应当尽量小,以符合 IAB 的指示,即各工作组应"对保持 SNMP 简单的必要性极其敏感"。尽管对反映在本备忘录中的 SNMP 修改投入了大量细致的考量和讨论,但所得协议与其前身简单网关监视协议(SGMP)[8] 并不向后兼容。虽然协议的语法已经改变,但最初的哲学、设计决策和体系结构保持不变。为避免混淆,已为本备忘录所述协议分配了新的 UDP 端口。