跳到主要内容

1. 引言

要使用国际化电子邮件地址, 必须同时对电子邮件地址的域部分和本地部分进行国际化. 电子邮件地址的域部分已经国际化 [RFC5890], 而本地部分尚未国际化. 如果没有本文档所规定的扩展, 邮箱名称将受限于 7 位 ASCII 的一个子集 [RFC5321]. MIME [RFC2045] 虽然支持传输非 ASCII 数据, 但没有提供国际化电子邮件地址机制. 在 RFC 2047 [RFC2047] 中, MIME 为某些特定的消息首部字段定义了编码机制, 以容纳非 ASCII 数据. 但是, 它不允许使用包含非 ASCII 字符的电子邮件地址. 如果没有本文定义的扩展或功能等价的一组扩展, 要在电子邮件地址的任何部分包含非 ASCII 字符, 唯一方法就是使用 RFC 2047 编码, 将其嵌入 RFC 5322 [RFC5322] 所称的相关首部字段的 "显示名称" 中(在其他地方也称为 "名称短语" 或其他名称). 编码到显示名称中的信息在消息信封中不可见, 而且对于许多用途而言根本不属于地址的一部分.

本文档取代 RFC 4952 [RFC4952], 并反映了该文档发布后发现的其他问题, 共享术语和若干体系结构变更. 本文档废止 RFC 4952. 由于第 12 节所述的变更, 关于传输途中降级的实验性说明 [RFC5504] [RFC5825] 已经失去意义, 不再需要. 现请求 RFC 编辑将这三份文档全部移至历史状态.

本文交替使用代词 "he" 和 "she", 用于指代性别未确定的人.

本文档中的关键词 "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY" 和 "OPTIONAL" 应按 BCP 14 和 RFC 2119 [RFC2119] 的说明解释.