RFC 4456 - BGP Route Reflection: Un'alternativa al Full Mesh Internal BGP (IBGP)
- Pubblicato : April 2006
- Stream : IETF
- Obsoleta : RFC1966, RFC2796
Stato di questo documento
Questo documento specifica un protocollo standards track Internet per la comunità Internet, e richiede discussioni e suggerimenti per miglioramenti. Si prega di fare riferimento all'edizione corrente degli „Internet Official Protocol Standards“ (STD 1) per lo stato di standardizzazione e lo stato di questo protocollo. La distribuzione di questo memorandum è illimitata.
Avviso di Copyright
Copyright (C) The Internet Society (2006).
Riassunto
Il Border Gateway Protocol (BGP) è un protocollo di routing tra sistemi autonomi progettato per le reti TCP/IP. Tipicamente, tutti gli speaker BGP all'interno di un singolo AS devono essere completamente connessi (fully meshed) in modo che qualsiasi informazione di routing esterna possa essere ridistribuita a tutti gli altri router all'interno di quel Sistema Autonomo (AS). Questo rappresenta un serio problema di scalabilità che è stato ben documentato con diverse alternative proposte.
Questo documento descrive l'uso e la progettazione di un metodo noto come „route reflection“ per alleviare la necessità di un Internal BGP (IBGP) „full mesh“.
Questo documento rende obsoleti RFC 2796 e RFC 1966.
Indice
- 1. Introduzione
- 2. Specifica dei Requisiti
- 3. Criteri di Progettazione
- 4. Route Reflection
- 5. Terminologia e Concetti
- 6. Operazione
- 7. RR Ridondanti
- 8. Evitare Loop di Informazioni di Routing
- 9. Impatto sulla Selezione della Rotta
- 10. Considerazioni sull'Implementazione
- 11. Considerazioni sulla Configurazione e Distribuzione
- 12. Considerazioni sulla Sicurezza
- 13. Riconoscimenti
- 14. Riferimenti
- Appendice A: Confronto con RFC 2796
- Appendice B: Confronto con RFC 1966