5. Procédure pour générer un identifiant unique
Pour produire localement un identifiant unique, on génère simplement une valeur pseudo-aléatoire de manière cryptographique comme décrit dans la [RFC4086]. Cette valeur DOIT être d'au moins 96 bits.
Le plus gros goulot d'étranglement pour la mise en œuvre de cet algorithme est la disponibilité d'un générateur de nombres pseudo-aléatoires cryptographiquement sûr (CSPRNG) approprié. Dans tout environnement qui dispose déjà d'un PRNG sûr, cet algorithme décrit est beaucoup plus simple que l'algorithme décrit à la section 5 de la [RFC6222]. Les piles SIP [RFC3261] sont tenues d'utiliser des nombres aléatoires de manière cryptographique pour générer les balises To et From (section 19.3). Les mises en œuvre de communications en temps réel sur le Web (RTCWEB) [ARCH] devront disposer de PRNG sûrs pour mettre en œuvre ICE [RFC5245] et DTLS-SRTP [RFC5764]. Et, bien sûr, pratiquement chaque navigateur Web prend déjà en charge TLS, ce qui nécessite un PRNG sûr.