5. Procedura per Generare un Identificatore Univoco
Per produrre localmente un identificatore univoco, si genera semplicemente un valore pseudocasuale crittograficamente sicuro come descritto nella [RFC4086]. Questo valore DEVE essere di almeno 96 bit.
Il più grande ostacolo all'implementazione di questo algoritmo è la disponibilità di un appropriato generatore di numeri pseudocasuali crittograficamente sicuro (CSPRNG). In qualsiasi contesto che disponga già di un PRNG sicuro, questo algoritmo descritto è molto più semplice dell'algoritmo descritto nella Sezione 5 della [RFC6222]. Gli stack SIP [RFC3261] sono tenuti a utilizzare numeri crittograficamente casuali per generare i tag To e From (Sezione 19.3). Le implementazioni di Real-Time Communications on the Web (RTCWEB) [ARCH] avranno bisogno di avere CSPRNG per implementare ICE [RFC5245] e DTLS-SRTP [RFC5764]. E, naturalmente, essenzialmente ogni browser web supporta già TLS, che richiede un PRNG sicuro.