5. Procedure to Generate a Unique Identifier
To locally produce a unique identifier, one simply generates a cryptographically pseudorandom value as described in [RFC4086]. This value MUST be at least 96 bits.
The biggest bottleneck to implementation of this algorithm is the availability of an appropriate cryptographically secure pseudorandom number generator (CSPRNG). In any setting that already has a secure PRNG, this algorithm described is far simpler than the algorithm described in Section 5 of [RFC6222]. SIP stacks [RFC3261] are required to use cryptographically random numbers to generate To and From tags (Section 19.3). Real-Time Communications on the Web (RTCWEB) implementations [ARCH] will need to have secure PRNGs to implement ICE [RFC5245] and DTLS-SRTP [RFC5764]. And, of course, essentially every Web browser already supports TLS, which requires a secure PRNG.