5. 一意の識別子を生成する手順
一意の識別子をローカルで生成するには、[RFC4086] で説明されているように、暗号学的に疑似乱数値を生成するだけです。この値は少なくとも96ビットでなければ「なりません(MUST)」。
このアルゴリズムの実装における最大のボトルネックは、適切な暗号学的に安全な疑似乱数ジェネレーター (CSPRNG) が利用可能かどうかです。すでに安全な PRNG を備えている環境であれば、ここで説明するアルゴリズムは [RFC6222] のセクション5で説明されているアルゴリズムよりもはるかに単純です。SIP スタック [RFC3261] は、To および From タグを生成するために暗号学的な乱数を使用することが要求されています(セクション 19.3)。Web 上のリアルタイム通信 (RTCWEB) の実装 [ARCH] は、ICE [RFC5245] および DTLS-SRTP [RFC5764] を実装するために安全な PRNG を持つ必要があります。そしてもちろん、実質的にすべての Web ブラウザはすでに TLS をサポートしており、TLS には安全な PRNG が必要です。