Aller au contenu principal

1. Introduction

En IPv4, le champ Identification (ID) est une valeur de 16 bits qui est unique pour chaque datagramme pour une adresse source, une adresse de destination et un protocole donnés, de sorte qu'il ne se répète pas pendant la durée de vie maximale d'un datagramme (MDL) [RFC791] [RFC1122]. Tel qu'il est actuellement spécifié, tous les datagrammes entre une source et une destination d'un protocole donné doivent avoir des valeurs d'ID IPv4 uniques sur une période correspondant à cette MDL, qui est généralement interprétée comme deux minutes et est liée au délai de réassemblage recommandé [RFC1122]. Cette unicité est actuellement spécifiée pour tous les datagrammes, quels que soient les paramètres de fragmentation.

L'unicité de l'ID IPv4 est couramment violée par les dispositifs à grande vitesse ; si elle était strictement appliquée, elle limiterait la vitesse d'un protocole unique entre deux points d'extrémité IP à 6,4 Mbps pour des MTU typiques de 1500 octets (en supposant une MDL de 2 minutes, en utilisant l'analyse présentée dans [RFC4963]). Il est courant qu'une connexion unique fonctionne bien au-delà de ces débits, ce qui indique fortement que l'unicité de l'ID IPv4 telle que spécifiée est déjà sans objet. En outre, certaines sources génèrent des ID IPv4 invariables depuis de nombreuses années (par exemple, les téléphones cellulaires), ce qui a conduit à la prise en charge de ce comportement dans la compression d'en-tête robuste (ROHC) [RFC5225].

Ce document met à jour la spécification du champ ID d'IPv4 afin de refléter plus fidèlement la pratique actuelle et d'inclure les considérations prises en compte lors de la spécification du champ similaire dans IPv6.