メインコンテンツまでスキップ

1. Introduction (はじめに)

IPv4では, Identification (ID) フィールドは16ビットの値であり, 特定の送信元アドレス, 宛先アドレス, およびプロトコルに対してすべてのデータグラムで一意であり, 最大データグラム生存時間 (MDL) 内で繰り返されないようになっています [RFC791] [RFC1122]。現在規定されているように, 特定のプロトコルの送信元と宛先の間のすべてのデータグラムは, このMDLの期間にわたって一意のIPv4 ID値を持たなければならず, これは通常2分と解釈され, 推奨される再組み立てタイムアウトに関連しています [RFC1122]。この一意性は現在, フラグメンテーションの設定に関係なく, すべてのデータグラムに対して規定されています。

IPv4 IDの一意性は高速デバイスによってしばしば違反されています。厳密に強制された場合, 典型的な1500バイトのMTUでは ([RFC4963] で提示された分析を使用し, 2分のMDLを仮定して), 2つのIPエンドポイント間の単一プロトコルの速度を6.4 Mbpsに制限することになります。単一の接続がこれらの速度をはるかに超えて動作することは一般的であり, これは規定されたIPv4 IDの一意性がすでに無意味であることを強く示しています。さらに, 一部の送信元は長年にわたって変化しないIPv4 IDを生成しており (例えば, 携帯電話), その結果, RObust Header Compression (ROHC) [RFC5225] でそのようなものへのサポートが生まれました。

本文書は, IPv4 IDフィールドの仕様を更新し, 現在の慣行をより正確に反映するとともに, IPv6の類似フィールドの仕様策定中に考慮された事項を組み込みます。