1. Introduction (简介)
在 IPv4 中, 标识 (Identification, ID) 字段是一个 16 位的值, 对于给定的源地址、目的地址和协议, 它对每个数据报都是唯一的, 因此它在最大数据报生命周期 (maximum datagram lifetime, MDL) 内不会重复 [RFC791] [RFC1122].按照当前规范, 对于给定协议, 源与目的之间的所有数据报都必须在该 MDL 期间具有唯一的 IPv4 ID 值, 该 MDL 通常被解释为两分钟, 并与建议的重组超时相关 [RFC1122].目前规定这种唯一性适用于所有数据报, 而不管分片设置如何.
高速设备通常会违反 IPv4 ID 的唯一性; 如果严格执行, 对于 1500 字节的典型 MTU, 它将把两个 IP 端点之间单一协议的速率限制在 6.4 Mbps (假设 2 分钟的 MDL, 使用 [RFC4963] 中给出的分析).单条连接的运行速率通常远超这些速率, 这强烈表明按规范要求的 IPv4 ID 唯一性早已失去意义.此外, 一些源多年来一直在生成不变化的 IPv4 ID (例如手机), 这导致在鲁棒头压缩 (RObust Header Compression, ROHC) [RFC5225] 中对此类 ID 提供了支持.
本文档更新了 IPv4 ID 字段的规范, 以更贴近当前实践, 并纳入在 IPv6 中类似字段的规范制定过程中所考虑的种种考量.