Aller au contenu principal

Appendix A. Références

  1. Ajout du code de réponse UIDNEXT. Correction de la référence de définition de UIDVALIDITY.

  2. Clarification supplémentaire de "can" (peut) par rapport à "MAY" (PEUT).

  3. Référence à RFC-2119.

  4. Clarification du fait que les décalages (shifts) superflus ne sont pas autorisés dans l'UTF-7 modifié.

  5. Clarification du fait qu'il n'y a pas de décalage implicite dans l'UTF-7 modifié.

RFC 3501 IMAPv4 March 2003

  1. Clarification du fait que "INBOX" dans un nom de boîte aux lettres est toujours INBOX, même s'il est fourni sous forme de chaîne.

  2. Ajout de la parenthèse ouvrante manquante dans la règle de grammaire media-basic.

  3. Correction de la syntaxe d'attribut dans mailbox-data.

  4. Ajout de UIDNEXT aux réponses EXAMINE.

  5. Clarification des réponses UNSEEN, PERMANENTFLAGS, UIDVALIDITY et UIDNEXT dans SELECT et EXAMINE. Elles sont désormais obligatoires, mais ne l'étaient pas dans les versions antérieures.

  6. Mise à jour des références avec les numéros de RFC.

  7. Vidage de text-mime2.

  8. Clarification du fait que les noms en UTF-7 modifié doivent respecter la casse, et que la violation de cette convention doit être évitée.

  9. Correction de l'exemple de UID FETCH.

  10. Clarification de UID FETCH, UID STORE et UID SEARCH par rapport aux réponses EXPUNGE sans étiquette.

  11. Clarification de l'utilisation du mot "convention".

  12. Clarification du fait qu'une commande n'est "en cours" qu'une fois entièrement reçue (en particulier, qu'elle n'est pas "en cours" pendant la négociation de continuation de commande).

  13. Clarification des valeurs par défaut de l'enveloppe.

  14. Clarification du fait que SP signifie un et un seul caractère espace.

  15. Interdiction des états aberrants dans la réponse LIST.

  16. Clarification du fait que ENVELOPE, INTERNALDATE, RFC822*, BODY* et UID d'un message sont statiques.

  17. Ajout du code de réponse BADCHARSET.

  18. Mise à jour de la syntaxe formelle selon les conventions [ABNF].

  19. Clarification du séparateur de hiérarchie final dans la sémantique de CREATE.

  20. Clarification du fait que la « ligne vide » est la ligne vide de délimitation [RFC-2822].

RFC 3501 IMAPv4 March 2003

  1. Clarification du fait que RENAME DOIT (SHOULD) également créer la hiérarchie selon les besoins pour que la commande se complète.

  2. Correction de body-ext-mpart pour ne pas exiger la langue si une disposition est présente.

  3. Clarification de la réponse RFC822.HEADER.

  4. Correction de l'espace manquant après le charset astring dans search.

  5. Correction du guillemet manquant pour BADCHARSET dans resp-text-code.

  6. Clarification du fait que ALL, FAST et FULL excluent l'apparition de tout autre élément de données.

  7. Clarification de la sémantique de l'argument de référence dans LIST.

  8. Clarification du fait qu'une chaîne vide pour SEARCH HEADER X-FOO signifie tout message ayant une ligne d'en-tête dont le nom de champ est X-FOO, indépendamment du texte de l'en-tête.

  9. Réservation explicite des noms de boîtes aux lettres 8 bits pour un usage futur en tant qu'UTF-8.

  10. Ce n'est pas une erreur pour le client de stocker un indicateur qui n'est pas dans la liste PERMANENTFLAGS ; toutefois, le serveur ignorera soit le changement, soit l'appliquera à la session uniquement.

  11. Correction/clarification du texte concernant les décalages superflus.

  12. Correction des erreurs typographiques dans la section « Changes ».

  13. Clarification du fait que STATUS ne doit pas être utilisé pour vérifier les nouveaux messages dans la boîte aux lettres sélectionnée.

  14. Clarification du comportement de LSUB avec le caractère générique "%".

  15. Changement de AUTHORIZATION en AUTHENTICATE dans la section 7.5.

  16. Clarification de la description du type de corps multipartie.

  17. Clarification du fait que STORE FLAGS n'affecte pas \Recent.

  18. Changement de "west" en "east" dans la description du fuseau horaire.